Unused Output Is Actually In Use For Track/Staff In Project


I am new to Dorico and have been spending a good deal of time configuring it to existing templates in VEPro. Everything seems to be working fine except I just stumbled across something I can’t seem to fix or make sense out of. I apologize if it has been brought up before.

Pretty straightforward here. For my first instance of Omnisphere, it starts on Port 7 channels 1-8. The outputs are:

Channel 1 = OUTPUT = 161/162
Channel 2 = OUTPUT = 163/164
Channel 3 = OUTPUT = 165/166

In Dorico, I have set the Port to 7 and configured the appropriate channels. I can hear sound, and I can see activity, however the sound and activity is coming from “Unused” outputs not the assigned Track Names. And the assigned “used” (colored) track names have no activity showing from the faders and also the wrong OUTPUTS listed.

In these pictures you can see the Perc. Hit is assigned in Dorico to Port 7, Channel 3 which technically are OUTPUTS = 165/166 and assigned as such in VEPro. The problem is Dorico has assigned the “used” Perc Hit track OUTPUTS to 197/198 and I’m not sure why yet. It also doesn’t show any activity on the assigned “used” fader. Instead, it shows (and again you can hear) the activity coming from the “Unused” output fader, which technically has the correct OUPUTS settings assigned in VEPro.

DORICO Settings:

So there is a mismatch and I’m not sure what to do yet to fix this. An option to change the outputs/bus would be great.

Thanks for any help you can provide.

VEPro Settings:

Welcome to the forum, @forestg074.

It would definitely be useful to be able to configure the way Dorico handles outputs for plug-ins in a more sophisticated fashion. Right now, it has a very simplistic approach: it simply shows the outputs that are presented by the plug-in, and labels them according to the instrument it thinks is on them, assuming that channel 1 will return on output 1, channel 2 will return on output 2, and so on. I assume that your output routing in VE Pro doesn’t match this simple configuration, and so Dorico doesn’t label the used fader correctly.

We plan to provide greater flexibility in this area in future, but for the time being, you don’t really have any options on the Dorico side: you would need to change your VE Pro configuration to bring it in line with Dorico’s simplistic assumptions.

Sorry for the inconvenience!

Hi Daniel,

No worries at all and thank you for your response, it prompted me to dig a little deeper into the template’s output settings in relation to Dorico., and I was able to make sense of it and find the solution.

The quick reason for the problem is that I skipped over some outputs that Dorico must have been looking for. I readjusted them to all be in perfect numerical succession and problem solved.

The more detailed answer if it is helpful:

In VEPro, the first 128 outputs were all “in use” and in numerical succession from 1/2, 3/4, 5/6, etc, through 127/128 with KONTAKT instances.

I then had 3 instances of Spitfire “in use” set to 129/130, 131/132, and 133/134.

At this point, I decided to “not use” or assign any more outputs and leave 13 more channels for single instance samplers available.

Then I resumed assigning and “using” outputs for instances of Omnisphere beginning with 161/162, 163/164, 165/166, etc…

So that left a gap of “unused” outputs and this skipping over and interruption of the numerical succession is where I assumed the problem was.

At that point, it was an easy fix to get Dorico and VEPro matched up properly. I changed the outputs in VEPro to all be in succession without skipping or leaving any “unused” and adjusted my ports and order of instances.

Lastly, I deleted the VST/VEPro plugin from Dorico and then reloaded a fresh one, and the problem was solved.


My last question is, can you work with and add more than 256 outputs and tracks in Dorico? I have larger templates to try next.

Thanks again for your help and for leading me in the right direction.

I’m glad you were able to fix this up easily enough! I’m not actually sure if there is a practical limit on the number of outputs.

Thanks Daniel!

Well, I’m going to find out soon! I’ll report back when I do.