Unwanted clef

I need to eliminate the bass clef in the second ending. Properties Panel>Clef>Hide doesn’t work as expected and simply deletes the clef so the notes go into the treble clef.

I read about inputting an “invisible clef”, but can’t figure out how to make that bass clef invisible. When I select the clef and type in the popover “invisible”, the clef is deleted, not made invisible. Help…

Now I notice that “invisible” makes the clef at the beginning of the next system invisible. Hmm…

The “invisible clef” is actually an invisible treble clef. I made a doricolib file to add an invisible bass clef and posted it here. Of course, you’ll then have the issue that you’ll need to add a real bass clef on the next system, and Dorico won’t let you hide the cautionary clef, so you’ll have to start a new flow or use a coda. (The ability to hide cautionary clefs has been requested a bajillion times.)

1 Like

You can Scale it to 1%, and the tiny clef will be hidden by a staff line, (and also take no additional space):

Screenshot
(that’s actually 5%, just so you can see it.)

but you can kill it with fire by setting the Opacity to 0%.

Screenshot

1 Like

Thanks, FredGUnn. It’s helpful to know the limitations. What a mess. Work-around time.

Thanks, benwiiggy. That’s a better work-around than the one I came up with. I just inserted a fake treble clef in the previous measure. Yours plays back. Got to remember the opacity for hiding things.

1 Like

IIRC, when one uses opacity, one has to Print in Color (unless that has recently been changed).

I think there was a change that if it’s 0%, then Mono doesn’t show it.

But a transparent object still takes up space, unless you resize it, too.

1 Like

Yes, my workaround preserves the correct spacing.

Unfortunately this does no longer work in Dorico 5!

Can you be more specific, @lim.usic? What are you trying to do, and what are you finding does not work?

Sure; what I meant here was that benwiggy’s suggested method to hide clefs by setting the color to white/the opacity to 1% or the size to 1% unfortunately does not work in Dorico 5. This would indeed help a lot. And your suggestion in another thread to enter an “invisible” clef works only in percussion staves.

At the moment I am struggling with a percussion layout to suit my intention. I would like to hide all sorts of instructions for players of multiple instruments - useful in parts, but superfluous in the score. I seems that I have to uncheck “allow instrument changes” for this - despite the fact that the players of multiple instruments have to change! - I still have to find out if this produces some other unwanted effects or not.

The issue is not that Ben’s suggested overriding of the colour or custom scale of the clef no longer works. Rather, the issue is that instrument changes produce automatic clef changes that are not “real” clef changes, i.e. they do not have a selectable clef.

I see; of course we don’t have the view behind the curtain…

If you create a clef change to an invisible clef on the percussion instrument in galley view prior to the instrument change, that should have the desired effect.