Unwanted split bars, can't edit

I’m writing a score with three staves, each with individual time signatures, but the bar lengths in sync, so that the individual time signatures are for grouping only For example: staff 1 has [4+4+5+5]/8. staff 2 has [5+4+5+4]/8 and staff 3 has [6+6+6]/8. Apparently the Engraver can’t handle this. Dorico splits the bars across systems. (“Allow open bars to be split” is unticked in the Layout Options). Neither Create System Break or Make Into System work correctly. The screenshot shows how bars 13 and 15 get split (the previous system has bar 12 and the first half of bar 13). Dorico does not let me make bars 12 and 13 into a system or add a system break at bar 15. Will I need to re-write the whole score without the individual time signatures, creating the independent groupings with Force Duration? Or is there a setting I’ve missed?

Are you able to post the project (or a cut-down extract) here so that others can do some experimenting to see if this problem can be sorted out?

This file has the problem. It’s all in 18/8 but the individual groupings vary in hidden time signatures. Dorico splits the bars across systems. I am unable to

  1. insert a System Brake after the first bar
  2. Make bars 1 and 2 into a System
    split bars.dorico (1.5 MB)

This is indeed problematic. I have resorted to the good old empirical method of trial and error - try something, if it doesn’t work, try something else.

This might not be exactly what you are trying to achieve, but it might help.

What I did.

  1. Show signposts.
  2. In Engrave mode, select the barline at the end of bar 1 and insert a system break. For me, it appeared at the start of bar 1!
  3. Then, in Write mode, use alt+right arrow to move that system break until it is at the start of bar 2.
  4. While the system break is still selected, alt-click on the first note in bar 4 (to paste a copy there). A system break should appear at the start of bar 4.
  5. Hide signposts.

Hopefully this technique might enable you to make some progress, but I have no idea what the underlying cause is.
split bars (ed).dorico (1.5 MB)

Curiously, when I selected all and filtered for time signatures then deleted them all in one go, I was left with a time signature at the start of 28/8. I don’t know the history of this document, but maybe that might be influencing what is happening.
Returning to the original of the project you uploaded, deleting all 4 local 18/8 time signatures at the very start (1 for each staff) and changing the resulting global 28/8 time signature to 18/8 gave the following, in which from bar 2 onwards your varied 18/8 groupings appeared to remain intact. If all goes well, you might have to redo the local time signature groupings only for bar 1 (or maybe just redo the beaming manually in bar 1).

split bars (ed-2).dorico (1.5 MB)


Thank you very much, that was brilliant! I followed your steps and got the exact same result as you did. I had looked at the signposts and deleted unwanted ones for this demo document but when the System Break I’d tried to insert at the end of bar 1 curiously appeared at the start of bar 1, it never occured to me to move the System Break around in Write mode. As to the 28/8 time signature, this does seem to be the cause or at least part of the problem. The original piece has a dozen bars in 28/8 (in varying groupings) first, and then this passage in 18/8 comes. Each 28/8 bar nicely fills one system but when the time signature changes ro 18/8, these layout problems appear. I will look into this and try redoing the initial bars. Thank you for your excellent advice.