Unwanted SysEx Data Midi Track

I’ve used Superior Drummer 3 with CB 10.5 for quite a while and have never had an issue.
However, for the the last few days, whenever I drop an SD3 pattern into a CB drum track, CB creates its own “SysEx Data” Midi track. The particular song I’m working on requires different 1 or 2 bar fills every couple of bars. Each imported fill creates it’s own "SysEx Data track. Deleting a track every time I drop a fill into CB is getting quite tedious.
Anyone know how I can I stop this?
This is quite possibly a Superior Drummer issue, but thought I’d ask here first.

EDIT: It would appear to be a Superior Drummer issue. I just checked my SD3 update history. Seems the problem started after I updated :frowning_face:

Have you found a solution to this?

Yes, I have!
I felt that it was probably a Superior Drummer issue, so posted the same question there and got this reply…
“You need to turn off “Auto Dissolve Format 0” in Cubase preferences > MIDI > MIDI File.”
This fixed it for me.
The problem was introduced in the 3.2.7 update. It must be a bug. I would never in a month of Sundays have figured that out :exploding_head:

2 Likes

I guess there are two surprising things going on: one is that the exported MIDI file has any SysEx info; the other is that “Auto Dissolve Format 0” is enabled by default, since format 0 means “one track”.

Thank you. This was driving me nuts.

I also thank you very much. I’ve been suffering from this for weeks now and I’ve tried almost everything in the preferences / MIDI menu. Fortunately your solution works. :+1:

Kevets, you are a hero! For some reason I put up with this pita for a very long time!