Update 3.2 Unacceptable Latency

On my iPad Pro 10.5, the 3.2 Update has increased latency in both the audio and MIDI inputs. The only workaround is to disable “Background Audio” which is very inconvenient when you’re using other apps/instruments. Latency has been a persistent problem, but usually a quick replug or restart was able to correct it. With 3.2 it can be triggered the slightest stress, like toggling a button and will come right back. Just when I thought Cubasis was perfect, and now this. I’m still using iOS 13.7, but is this happening to anyone else?

So I updated to iOS 14.3 and the latency got even worse. Now, even with the Background Audio turned off, there is unacceptable latency in the MIDI throuput and audio. I can’t use my e-drums to trigger Cubasis. Makes no difference whether there are plugins involved, besides, that shouldn’t be considered a workaround. What system was Cubasis Update 3.2 tested on? LATENCY is a serious deal breaker.

Is it iOS? I don’t think so, Garageband and Cubasis 2 are working fine on iOS 14.3. Cubasis 3 would be my preferred DAW. Any suggestions welcome.

Yes I had the same issue with 3.2 update that occured randomly, but today that works…I hope tomorrow also…

Hmm. It seems to be a resource issue. Toggling off “arm on selection” reduces the latency. You can do it in Cubasis2 and Garageband, so this a huge step back despite the improved features. Testing continues…

Hi all,

Please have a look at our dedicated Cubasis 3.2 | Multicore-rendering & Latency Settings article, which hopefully is of help for you!