Updated Helix Native, Now It Won't Work In Cubase and Causes a "Serious Problem"

Hi All.
Hope someone can help with this.

I use:
Cubase 10.5 Pro, Windows 10, Well specified PC.

I also use:
Native Instruments Komplete Keyboard and Komplete 12 software.
Line 6 Helix Native.

The PC was completely rebooted to be “as new out of the box” fairly recently, and I have kept any programmes placed on it to a minimum, so there isn’t much on it besides the obvious things that come with W10 and the above music software. There has never been any “dodgy” software loaded.

All has been running well until very recently, but as I hadn’t been doing much playing recently, I hadn’t updated things for a while.

I have two issues, the first of which I will make the subject of a separate post when I understand a solution, and the second, which is a major problem and the crux of this post.

FIRSTLY:
Last week, I updated all the instruments which required updating in the Native Instruments pack, using the Native Access tool. All updated successfully, but when using in Cubase some of the instruments were “unavailable”. I could hear the sample when scrolling through them (as you should), but when selecting an instrument, some were not available. I can see that there are quite a large number of Native Instruments files in the blocked section of Cubase.
Until updating the NI files, I had no problem using them.
However as Cubase still operated properly except for these unavailable instruments, this isn’t the crux of this post - I have placed a query with NI about this and will report back with a separate post when (if!!) I get a solution.

SECONDLY, and the crux of this post:
Yesterday, I updated the firmware on my Helix Floor from Version 2.92 to Version 3.11, with as far as I know no problems.

As I had done this, I also updated my Helix Native the same. I have logged an issue with L6 about this, but as it now affects Cubase, this is what happened:

Using the L6 process, selected VST3 plug in and AAX plug in to be loaded (I’ve since realised that AAX plug ins are for Pro Tools…doh).

When clicking to install, I got the following error message:

“Error when opening file for writing:
C\Program Data\Line6\Helix\Native\res\fonts\Avenir NextCondensed-Bold.ttf”
I’ve never seen this type of error message before when updating Native.

I got the options of
“Click abort to stop the installation, Retry to try again, or Ignore to skip this file”.
Clicking retry did nothing (unsurprisingly) so clicked “Ignore”.
This resulted in a similar error message except with “…BoldItalic.ttf” at the end.
I continued clicking “Ignore” which resulted in another similar error, this time with another font type. I continued clicking ignore, and similar errors appeared with different fonts named. I clicked around 10-15 times until no more font error messages appeared.

But on the final “ignore click”,I got the message:
“Error opening file for writing: C:\Program Data\Line6\Helix Core\Helix Core Win_x64.ddl”

Clicking “Retry” did nothing.
Clicked “Ignore” and the program completed installing. Got the message “Helix Native v3.11 has now been installed on your computer”.

Hurrah !!

BUT, rebooted the PC and loaded Cubase.
Got the following error message:

If I left it at the first Preferences option (ie Use current program preferences), Cubase loads.
I created a blank new project. Loaded OK.
I selected Guitar Rig5 as an input. This loaded and worked OK. At first I got no input signal and no sound out, but after changing the channel settings, got it to work as it should (wouldn’t previously have had to do this).

I then opened another track and selected Helix Native as the input.
The input loaded, but all greyed out and with the following error message:

Obviously, cannot use Helix Native now.

When I removed this track, Cubase did this:

If I load Cubase from scratch but using the second Preferences option, it loads and a window opens telling me to register the product (it is) and so I selected the “already registered” option.

Loading a new blank project and selecting Line 6 Native as an Input created exactly the same as described above, including no input signal and sound until I had amended the audio connection settings.

If anyone has any idea what’s going on I would be most grateful.

I have had the orange band Line 6 warning at a previous update, where the solution was to deauthorize and reauthorize the PC. I have tried this and this time it has had no impact on the problem.

I am wondering if I could uninstall Helix Native and reinstall (this time leaving out the AAX file) to resolve this issue ???

I’m hoping that I don’t have to uninstall and reinstall NI Komplete as that is a MASSIVE file which takes an age to load.

Ditto Cubase, but probably less of a pain.

Any help most gratefully received before I log it with Cubase in case they can help.

Helix Native.
SIMPLE RESOLUTION !!

Uninstalled Helix Native and reinstalled with just the VST3 files.
ie DO NOT leave AAX files ticked.

Still no solution to the Native Instruments issue though.

Silly me.

Hi,

To me it looks like NI broke something (a bug has been introduced) in the update, so the plug-ins don’t pass Cubase tests. Therefore the plug-ins are blacklisted after the update. Yo can remove them from the blocklist manually on your own risk. You take the risk, Cubase could become unstable.

Out doesn’t matter, if you install AAX or not. The AAX plug-ins are living in totally different folder, which Cubase doesn’t scan at all and doesn’t know about it.

I would try to reinstall the plug-in as administrator.

This looks quite scary for me. Cubase shouldn’t scan this system folder and come across the ntdll.dll. Double-check the VST Plug-in Manager > VST 2 Plug-in Path Settings, please. Make sure, only meaningful paths are set here. No C:\ drive as the whole, no C:\Windows, etc. Only the folders with the VST plug-ins, please.