Updating Download Manager hangs on two computers

Updating to the latest, on 2/3 computers (a PC and a Mac) the Download mgr wants an update, and it hangs on both at the same point - at the end of its download from the internet (the progress bar just got to the end). It hangs there for some time, then errors out


One computer updated fine. On the Mac, thinking there might be a file lock somewhere or something I rebooted, but same issue. Suggestions?

Can you attach the logs from %APPDARTA%\Steinberg\Download Assistant (Windows) and ~/Library/Application Support/Steinberg/Download Assistant (macOS)?

here’s the Mac, I’ll dig up Windows

Download Assistant.zip (10.0 KB)

There’s nothing in the Windows directory, otherwise any help Dan?


%PROGRAMDATA%\Steinberg\Download Assistant\Logs

1 Like

Did you get a chance to look at this @dspreadbury? Problem is persisting, I just can’t update on these two computers, really odd.

Why do I still need to update the Activation Manager to open Dorico? Why does updating the Activation Manager still need to update eLicenser?

No, unfortunately the Mac logs don’t show anything. Did you find the Windows logs in the location suggested by Craig?

You don’t need to update Steinberg Activation Manager to run Dorico, but it is advisable to keep Steinberg Activation Manager up-to-date to take advantage of any new features and fixes in Steinberg Licensing.

Steinberg Activation Manager itself does not update eLicenser Control Center: but Steinberg Download Manager will keep both SAM and eLCC updated. eLCC is still required for the time being because the transition to Steinberg Licensing is not complete for all Steinberg products. Dorico itself does not require eLCC, but other Steinberg products and content do for the time being.

only has an old installation log there. This machine is Win 11, the other (was) Win 10 when I updated.

SDA_Installation_2021-08-12_17-19-14.zip (1.8 KB)

Hm, so how do I fix this?

These are the specific bits of information our SDA developers have requested for bug reports:

  • Mac/Win version (7/8/10/Mojave/Catalina, Home/Pro/Enterprise, 32/64bit)
  • SDA version
  • Steps to reproduce the error
  • Screenshot of the actual error
  • SDA installation logs: (Windows: C:\ProgramData\Steinberg\Download Assistant\Logs\ ; Mac: /Library/Logs/Steinberg/Download Assistant)
  • SDA application logs (Windows: C:\Users<USERNAME>\AppData\Local\Steinberg Download Assistant\logs ; Mac: ~/Library/Logs/Steinberg/Download Assistant)
  • Whether antivirus software is installed and which exactly
  • Is VPN running?
  • Is any proxy configured?
  • Any other known firewall, apps or network configuration that might interfere with other applications or network?

Actually, I did. Dorico suddenly wouldn’t run without doing that. Maybe something to do with the VSL change over to iLok?

  • Mac = Catalina, Win = 11 Pro
  • Run the download manager, it requests and update, say yes
  • Logs given above
  • No VPN running
  • No proxy, the mac is on gigabit the laptop on
  • No firewalls or special network configurations

i.e. nothing useful to determine the issue. When I get these I take it to mean the application isn’t doing good enough error detection, the missing logs being a particular issue. Something I rarely see engineers do strangely is go back and add better diagnostic code, simple logging checks would make everybody’s life easier. Anyhow if they were up to it I could install a new version with the log checks, but just installing a new version might fix it anyhow.

Arg … well whatever, I expect they won’t want to do that, I’ll try reinstalling and see if that fixes it. Sign of desperation.

I’m trying to help a friend activate and run D4 on his Mac running MacOS Big Sur. When he runs the Steinberg Download Assistant, it tries to update the “Steinberg Activation Manager (42 MB)”. It then just hangs, with the spinning blue rings. I helped him kill the relevant processes in Activity Monitor that you mentioned, and we tried again, same result.

He already owns D3.5 and we think he would qualify for the grace period upgrade (according to a Steinberg US chat agent), but at this point I don’t know what to tell him…

Your friend might try downloading and installing the most recent version manually, from here: Steinberg Activation Manager | Steinberg. Even if that doesn’t work it’s possible that that might provide a more informative error message.