Upgrade - going round in circles!

Ok, so I decided to upgrade to Dorico Pro 4. I installed the product using the dowload manager but I can’t seem to licence it or activate it. I am not sure if it’s old style Elicencer/USB or new something or other. When I go round the many loops and labriyths nothing seems to work.
If I put my “Activation code/Download activation Code” into the elicencer it seems to be a few digits short and tells me that I need to upgrade my elicencer, which I have already done today - twice.
If I try to run dorico, the Activation manager pops up and a pop up tells me to “Switch to activation manager” (which it already is) and follow the pop ups - which is the pop up I am reading and gives me the only unhelpful option to quit.
The “More information” button it takes me to a page talking of “Download Access Codes” which is different to “Activation codes”.
I also tried to enter my code into the elicencer and found a button half concealed in rthe non expandable window on the bottom right. I could not read the text but pressed it and it seemed to upgrade (a green moving, line) . Now, in the elicenser it states that Dorico Pro 3.5 is “upgraded to Dorico 4”, but my product still will not run. If I click the Dorico 4 shortcut on my desktop it says “no licence found” and I go around the loop again.

What on earth is happening I have NO clue!

Dorico 4 does not use the eLicenser. Enter the DAC into the Steinberg Download Assistant.

1 Like

Thank you Graig but when I try this the following happens. In download assistant a pop up states "You have recieved your licence activation … do you want to upgrade your licencenow? " I press the upgrade button. Another pop up appears (looks like an e licencer window) with an activation code already insterted. I hit continue… An elicencerwindow comes up with a big red cross “No licence To Upgrade selectable”.
I am still lost as to what I should be doing


You will probably need help from Dorico support. You should probably untick the Solution button. That tells Dorico support your issue is resolved.

I am amazed that ZeroZero is having the same experience that I had back in January and again in February. I recall the button half concealed in the non expandable window on the bottom right and am surprised that this has not been fixed yet.

My path to successful activation is told here.


OK, so I managed to get my licence activating. Here is how, though it makes NO sense. Sign out of SAM (activation manager) sign back in again. Here I see a message stating if I proceed ALL my “offline” licences will be deactivated. I have never activated a licence “offline” to my knowledge. Having tried numerous other options I opted for yes. This deactivated both Cubase 12 and Dorico(s) I then activated them both and they both work - for reasons unknown.
Hint: first time run stalled on loading audio engine. Second time run parsed my VST instruments (I have a lot) which took 2 minutes or more, blacklisting some VST2s I expect, (though this was not explicitly said), then it eventually opened.
The whole activation process has taken me 3 hours over 2 days and is totally non informative and non intuitive. IMO it needs improvementJust because Steinberg understands it’s jargon, this does not mean it’s users do

1 Like

Glad you are up and running.

The spurious warning about “offline licenses” is unfortunately a bug in SAM 1.3, for which we hope to have a fix in the next SAM release. (The warning is needed when using offline licenses, but at present it can also appear in other situations, particularly if upgrading from SAM 1.0 or 1.1.)

Thank you for listening. To the average user “offline licence” surely means when you register a product without connecting to the internet. For Steinberg it seems to mean something else. Also why did I have to delete my Cubase licence to fix dorico? One further gripe with Steinberg’s (global) downloading/licensing process is that there seems to be no way of easily finding all products need to be updated when you have a lot of products. This seems a very odd ommission. Native Instruments have done a much better job, in their systems, you simply launch Native Instruments Access, you get a clear list of all your products (and a nice pic) and if one needs updating, it will say so. No need for a sperate library and activation manager.
Please - something simple and effective


Thank you so much for sharing your fix, ZeroZero. Actively signing out and back in again within the activation manager application seems to have fixed a similar problem for me. Odd, when it didn’t have the same effect when I had to sign in again after completely uninstalling and reinstalling both the activation and download software.

To describe the problem I had in case it’s helpful for anyone, including any of the developers, I was getting a “No License Found” warning from SAM whenever I opened Dorico 4 (Dorico 3.5 worked fine - maybe to do with newer software not using the older e-licenser software?). When I then opened SAM, nothing would happen when clicking the “activate” button. The product appeared as activated in the software tab of my online account.

It might be worth making sure that support is aware of these issues as I’ve had a back and forth with support for a week just trying to get me to do basic IT checks (right click and run as administrator etc.) that’s been frustrating when it’s clearly a software glitch that I’ve finally fixed by trawling the forums. Thank you