Upgrade to version 6 throws license exception

I had version 5, but after updating Windows 10 to version 2004 that no longer worked.
So I decided to get the version 6.
It downloaded and installed and I have the license in the elicenser, but when I start it I see this:


I had a similar issue with Padshop Pro so I upgraded that to Padshop 2 and the same situation occurs.

I had a live chat session and someone is looking into this, but so far no answers, so I thought I should post a warning about Windows 2004 update, which may be the problem.

I’ve gone through most of my audio software and other applications and I have not encountered issues until I ran across this one.

I’m having the same issue after updating Windows 10 Pro to version 2004.
Spectral Layers 6 stopped working with the soft eLicenser version 6.11.10.2269.
Running the Online Synchronization & Maintenance doesn’t solve the problem, neither does running as an Administrator.
All my other applications are fine.

The error message is: Application ‘SpectraLayers Pro 6’ has caused the following error:
The Soft-eLicenser threw an unknown exception.
Options:

  • Click to abort.

I think maybe somehow the new security measures in the update are causing this problem.

I had exactly the same problem after installing W10 Home b2004 and then found that SpectraLayers Pro 6 wouldn’t load and just presented the eLicenser error. I went around in circles with the eLicenser and My Account for about an hour. So frustrating. I ended up uninstalling SpectraLayers Pro 6, the eLicenser and the updater. I then CC Cleaned the registry and re-installed SL6. It worked - well, so far it has.

While I don’t recall exactly what I did, I certainly uninstalled and re-installed Spectralayers 5 and 6 as well as the elicenser.
I don’t know what you mean by updater? The Download Assistant? I didn’t try uninstalling that.

Yes, the Download Assistant. Sorry about that.

here no problems on win10 home and pro 2004. but i have a dongle.
that will the difference.

Oh dear, I uninstalled everything and now I can’t get anything to work, starting with the eLicenser.
I’ll have to start a chat sesssion with someone who understand all this licensing voodoo.

https://helpcenter.steinberg.de/hc/en-us/articles/360014716899-eLicenser-Control-errors-with-Soft-eLicenser-based-products

That was an interesting read, but unfortunately it is not related to this problem.

I already went through those steps, anyway.

I logged a support request about a week ago and have not had any feedback yet.

One of the more serious issues is that the eLicense server does not even display its dialog box in the correct format.
It truncates the window and does not show the buttons on the bottom, so one has to use Windows Tab key to select the ‘hidden’ button and then Enter key to accept the ‘mouse click’.

Here is what the malformed window GUI looks like.

I called support again and got this straightened out.
The tech guru used an application called ‘elc-installation-helper.exe’ to get things fixed up.
Now SpectraLayers 6 and Padshop 2 are working fine.

I was able to resolve this issue by launching SpectraLayers as an administrator (right-click - “Run as administrator”). After doing that once I am now able to launch it without elevating to admin.

I had exactly the same problem after installing W10 Home b2004 and then found that SpectraLayers Pro 6 wouldn’t load and just presented the eLicenser error. I went around in circles with the eLicenser and My Account for about an hour. So frustrating. I ended up uninstalling SpectraLayers Pro 6, the eLicenser and the updater. I then CC Cleaned the registry and re-installed SL6. It worked - well, so far it has.

I had the same problem too, but I just right-click on it, then “run as administrator”, put my password and it worked