Upgrade - will not start - Cubase10.5 Elements


I have a problem. Please help.
A few days ago I purchased an upgrade to Cubase 10.5 Elements. I upgraded Cubase 6 Elements.
After installing the program and entering the key, I started the program. Unfortunately, after the “steinberg hub” window appears, the program stops working …

What can I do?

I work on Windows 10, Home 64 bit, Dell Vostro 3750,
Intel Core i5 ​​2410m, RAM 8GB, SSD 512 GB


Mam problem. Proszę o pomoc.
Kilka dni temu zakupiłem upgrade do programu Cubase 10.5 Elements. Zrobiłem upgrade programu Cubase 6 Elements.
Po instalacji programu i wpisaniu klucza, uruchomiłem program. Niestety po wyświtleniu okna “steinberg hub” program przestaje działać…
Co mogę zrobić?

Pracuję na systemie Windows 10, Home 64 bit, Dell Vostro 3750,
Intel Core I5 2410m, RAM 8GB, SSD 512 GB

Hi and welcome,

Does it mean, you can see the Steinberg Hub window and you cannot operate Cubase? Nothing happens, if you click somewhere in Hub? If this is the case, make sure, there is no other window hidden behind the Steinberg Hub, please.


There is no window. No button works. Dead screen.
To close Cubase, I need to start the task manager.


When you Mose hover over the Cubase icon in the Start bar, you can see only the representation of the Hub window, right? No other message there?

Is to on Windows possible to show all windows of given application (or all windows of all application) as it is possible on Mac? What do you see then?

If there is really no other window, use Microsoft ProcDump utility to generate a DMP file, please.


Yes, I see nothing else. No messages.

After pressing the desktop button, I have access to all icons and programs. Everything works.

To disable the “steinberg hub” I have to do it in task manager.

Manager view in the photo.

I will try to take a DMP dump later.


If you unfold the arrow on the left side of the Task Manager, you should see all the windows of the application, right? Or is it all processes?

Btw, have you tried the Microsoft ProcDump utility, please?


I can’t take a dmp dump.


Why not? The file has not been created, or…?

I’ve never done that. Where can I find this file?


Me neither, I’m not Windows guy. But I think the file is located at the same folder as the ProcDump application is.


I solved the problem. For now, everything works except video …
I found such help in the forum …

"…The Fix is:
Remove " “hubservice.dll” from the Components folder.
“hubservice.dll” Is a shell that interacts with the web and causes Cubase to crash when calling out to File Manager in Windows 10.

Remove that darn .dll file and cubase is crash free for me and many others. It’s stable… no crashes or buggy behavior…"

Thank you for your support and help