UR 22 mk II [V1.10.5] Audio dropout NOT FIXED

I’ve had no problems with my UR 22 for almost 2 years now until out of the blue, audio started dropping. It’s around 2 seconds and happens when my CPU is being maxed.

V1.10.4 to V1.10.5 Solved a problem in which USB data transfer could not be completed in time and audio dropout
would occur if a Mac with slower USB transfer spec was used with OS X 10.11 or later.

It happens when streaming audio & video, mixing in the latest version of Logic Pro X, etc. I’ve tried turning off WiFi but the problem continued.

This never happened before when my CPU was pushed. Like I said, only about two or three weeks ago did I start experiencing audio drop issues.

What I tried to get it fixed:

  1. Rolled back my OS from 10.14.6 Mojave to 10.13.6 High Sierra
  2. Rolled back my Yamaha Steinberg USB Driver from 1.10.4 to 1.9.4
  3. Tested my Mac on my friends UR 44, eliminating my system as the problem.

MacBook Pro (Retina, 13-inch, Early 2015) 2.7 GHz Intel Core i5 8 GB 1867 MHz DDR3

Is anyone else experiencing this issue? I don’t want to have to throw away my $200.

Same happening to me … just updated os Mojave and ur824 tools and USB driver… then started Dropping out … I’ve tried everything reinstalling the lot… my cpu isn’t even working hard. The cpu meter is not even 40%
Still doing it … I tried different soundcard… same so I think it must be a driver problem… I think I’m going to have to reinstall the os back to an old version. Which I don’t want to have to do

I tried that. I was on the latest version of Mojave and all drivers updated when I first experienced the issue. Then I reverted to High Sierra and even rolled back my driver. Problem remained.