UR 22 mkII phantom power problem

I just bought steinberg UR 22 mk II. And i’m having trouble when recording with +48v phantom power on + condenser mic.
I attached the situation, when i’m recording the audio via condenser mic, the audio recorded start clipped at someway that it just like reseting the power, and then after a while it come back recording with the normal, and all the suddent coming back again with “lost power syndrome”.

This is very frustrating, because i can’t be sure that my track is doing just fine, and so i cannot TRUST my UR22mkII to do her job.

I’ve update the driver and firmware to the most recent one.

Windows 10, 8GB RAM, i5, Dell Vostro
UR 22 mkII
Cubase AI 9.5.41
Driver Yamaha Steinberg 1.10.3
Firmware UR22 V.104

Please help me…i’m desperated :frowning: :frowning: :frowning:


Why do both the .wav file (instrumental) and my vocals recorded at the same time. I can hear the beat on my vocal track recording
Cubase 10 AI E

no answer yet?

Similar Issue here, pretty similar system,

Connected a Rode NT1 via new cable to the UR22 MKII, activated 48V, gained it. Fine Signal. But after a couple of seconds to a minute, I seem to lose the Phantom Power (while the 28+ LED is still red). I can still barely see a slight reaction on the PFL in Reaper if the Input is really loud, like a handclap, but no useable signal. Then it just comes back after the same uncalculatable amount of time, roughly a minute.
Tried it with the usb as power supply, just as with an 5V external supply.
Tried different USB Inputs as well.
The issue doesn’t occure with an dynamic mic without the 48V. A SM58 is doing the job constantly just fine. Just sounding like s**t obviously.

Yes, the same issue!!!
Finally someone reply on this thread.

I’ve tested 2 mic condenser and the same issue happened on my UR22 MKII.
It’s behringer B1 and samson C01.

But then…

I bought a new laptop, dell G7.
Still the same issue!!!

Then…
I bought a new mic condenser, audio technica AT2020.
SOLVED THE PROBLEM!

So, probably the problem was the mic condenser.
So far, the mic is ok, and not giving me a stress “wipe out” power while recording.

You might try also to change your mic condenser…