UR 22 not recognised by Monterey 12.4

Can anybody help since upgrading to Monterey 12.4 my UR 22 no longer works-it also no longer shows up in sound preferences. Do I re-install the previous version of Monterey?

Did you check The System information Tool too? Is your UR22 interface not listed?
You’re already using the latest Steinberg USB Driver (3.1.1), right?

Hi thanks for getting back to me I didn’t check in those two places however I did check in system preferences sound and the audio midi app but not showing. Since posting this I have now decided to go back to to 12 .3.1 which is a complete pain but there you go that will teach me to be so keen on doing an update!

If you’re using Time Machine as a backup solution, your pain should be only the time.


1 Like

Ive reinstalled Monterey 12.3.1 and reinstall Time Machine from yesterday. As you can see the driver is still not showing up, The only place the unit shows is the USB connector. When I reinstalled the driver there were some notifications that appeared saying that the next upgrade would not support the drivers. If anybody’s got any ideas I would appreciate any help.

Please read these two articles.
I think a driver re-install and checking the macOS security settings will solve your problem.

Many thanks for the articles I’ll look into it tomorrow morning. As a matter of interest are you on Monterey 12.4?

With a fresh pair of eyes and ears I solved the problem this morning. Go to system preferences > security and privacy>General. At the bottom of the panel there was a message saying “These applications need your attention” I unlock to the panel and open the dialogue box which showed 3 tick boxes for different items but also included a tick box for Yamaha. Problem solved

1 Like


1 Like

Great! That’s what I already guess. I’m happy that you could solve this.

Many thanks for the input-much appreciate. As a footnote if I do go up to 12.4 t for I wonder if I’ll get the same notice and all that needs to be done is the boxes being ticked-just a thought.