UR 22C Audio Dropouts - No Solution Worked

Hello,

I’ve tried “everything” to stop audio drops with UR 22C but nothing helps. I’ve tried these;
UR-C: Audio dropouts in SuperSpeed (USB 3.1 Gen 1) mode
Windows: Issues with Yamaha Steinberg USB Driver V2.1.0 or later

changed ASmedia USB drivers from Microsoft to ASmedia <> ASmedia to Microsoft
changed Superspeed USB 3.1 Gen 1 to USB 2

nothing helped

Then I’ve tried some other things like

Tried all USB ports, including USB 3, USB 2, Front/Rear
Changed BIOS settings;
XHCI Handoff Enable/Disable
USB Legacy Support Enable/Disable
Power Management Options

All I can say is nothing changed with “switching Superspeed to USB 2 mode”, same period audio dropouts…

Error Timestamp:
0: 0. 0 : 1 00000000
0: 0. 7 : 1 00000000
0: 0.35 : 0 6 7 8 11 IP80000000 ID00043cae OP00000000 00000000
0: 0.39 : 0 11 IP80000000 ID00007879 OP00000000 00000000
0: 0.40 : 0 6 7 8 00000000
0: 0.42 : 0 11 IP80000000 ID0000665f OP00000000 00000000
0: 0.44 : 0 6 7 8 00000000
0: 1.25 : 0 6 7 8 11 IP80000000 ID000502de OP00000000 00000000
0: 1.26 : 8 00000000
0: 1.32 : 0 11 IP80000000 ID0000d77b OP00000000 00000000
0: 1.33 : 0 6 7 8 00000000

Can somebody help please ?

Mainboard: MSI x99a Tomahawk
OS: Windows 10 Pro 21H2 Build: 19044.2130
CPU: Intel Core i7 6900K

I’m on an X99, 6850k build myself, with a UR824 and had all kinds of issues. Only got it working recently after almost 2 years. I installed driver version 2.0.3, and I followed all the steps in this link.

Might help. Good luck.

Thank you for your comment…But there is no “Windows UEFI - Other OS” option in X99a Tomahawk…

All I can see is "Windows 8.1/ 10 WHQL Support " and it means “The system will switch to UEFI mode to meet the Windows equirement.”
and I’ve tried that enabled/disabled before. I use it enabled

What more can I change ?

Are you using an NVIDIA Graphics Card?

Have you tried using the NVIDIA Studio Driver?
In the NVIDIA Control Panel, change Power Management to Maximum Performance and turn off Threaded Optimisation.

Did you install the Yamaha Driver v2.0.3?

I am just clutching at straws here, but that’s how I eventually got my UR to work. I know it’s a bit of PC acrobatics, time consuming, frustrating and annoying, and I almost gave up after 18 months. I feel as though there is a way to get your UR-C to work as it should.

Have you tried Latency Mon to see if it gives you any clues?

I have a ur22c as well on win 10. I find the driver seems to drop out periodically. Some days I can go for a whole session of several hours without problems. In the studio setup window I put no in driver- ok then swap it back to Yamaha ASIO driver then it works again.
I’m still running an earlier driver and saw no reason to update as it still happens on the latest driver.
I’m assuming you have wifi turned off and anti virus stopped?

I’m using Nvidia GTX1650
PowerManagement is set to always Max, didnt try to change Studio Driver…

Yes, I installed Yamaha v2.03

Btw I feel you & thanks for your help, yes all we can do is clutching at straws…

No antivirus & it’s a PC so no wifi.
Which driver version do you use now ?