UR-RT2 Mojave

Hello team,

I’ve just purchased a UR-RT2 and have updated my IOS to the latest version of Mojave. I have downloaded and installed the latest USB driver and everything looks as it should in terms of my preferences (also spoken to Steinberg support directly). However, when I record enable a track in Pro Tools (or any other DAW I’ve tried - Logic Pro X + Live 10) I can’t get any metering into the software. I’m still able to monitor direct through the interface though so I can hear signal as soon as I plug something in, but just not getting signal into the software.

Any tips or suggestions? Like to think I’m not a newbie to this game and it’s something on Steinberg’s end, but I maybe wrong. Cheers!


I’m facing the exact same problem as you. Did you get a response from Steinberg support or find a solution yet? I sent them a mail regarding this issue today, but I’m still waiting on a reply.

When I received my UR-RT2 a couple of weeks ago I first tried it on my old mac (running High Sierra), and I was able to record audio into Cubase without any problems. This week I switched over to a brand new mac with Mojave (10.14.1) pre-installed and that’s when I discovered no audio was going through the inputs into Cubase. Like you, I can hear the audio when enabling direct monitoring, but no signal is going into my DAW, which is a huge problem.

After a quick search on Steinberg’s website I came across a list of Steinberg hardware compatible with Mojave 10.14. UR-RT2 is on that list, but it’s listed as “Testing 1, 2, 4 UR-RT2”, whereas a lot of their other products are listed as “Compatible”. Not sure exactly what this means, but I assume they’re working on some sort of compatibility issues. An official statement from Steinberg on the topic would be nice.

It’s nice to know I’m not the only one experiencing the issue! I did get a reply from Steinberg support after I initially contacted them. They said to download the latest USB driver and/or re-install it but I have done that to no avail.

I also saw the compatibility list on their website, but when I’ve spoken with them there has been no mention of any ‘testing’ still being conducted so hopefully that is just the case and the issue will be solved soon.