UR12 Audio Interruption due to USB Error in Windows 11

Having this re-occurring audio dropout whether I’m casually listening or I use it to play my electric guitar with my headphones. It’s starting to get really annoying now.

I had this problem since I changed my PC, which is the first clue. My current rig is an AMD build, with 16GB RAM on Windows 11. My older PC is an Intel-based system with 10GB of RAM on Windows 10. I did take a look at a possible fix on this forum posted 2 years ago by dondawell about the same issue. Done it, still broken. I reinstalled older drivers ranging from v1.9.9 to the current v2.1.5 with each version, which still didn’t work. However version 2.1.4 ran the most ‘stable’ where the cutouts were less frequent.

This leads me to believe to a few things;

  • The driver is having a weird interaction with AMD on Windows 11 or the other way around.
  • My unit is faulty (Highly odd that it would fail when I switched but it could be pure coincidence)
  • USB Driver/Motherboard limitation, probably because it’s AMD(?) since i’ve seen posts about dodgey USB connections though i’m not sure how I can test this.

Can’t test on my old PC as I scavenged some parts from that to build my new one. I’m curious now how many AMD users on W11 have this issue.

Other things i tried:

  • LatencyMon test thing and it came out just fine with the results.
  • I did contact support relating to this problem and they haven’t gotten back yet.
  • Updated the motherboard BIOS, same result.
  • Unplugging every USB device other than the mouse and keyboard, which lead to slightly fewer cutouts
  • Updated AMD Chipsets and LAN services

If anyone has any more suggestions on what I can do please do so. Getting pretty impatient to pull the trigger on another audio interface. Though, I do have a last resort thing I can do which is to completely reinstall Windows 11. A huge inconvenience due to the sheer amount of stuff I have on that drive and wouldn’t know if it would work.

PC Specs

  • Ryzen 5 5500
    -16 GB RAM @ 3533MHz
    -ASUS PRIME B550M-K Motherboard
  • 3 SATA SSDs to a combined 1TB of storage

I have the same issues on 11th gen intel laptop with Windows 11 and my Yamaha driver version is V2.1.3. Driver’s panel told me something about USB error. I intend to make fresh Windows 10 install because of this. I’ll come back here when I’ll know more :smiley:

Edit 1: yeah, „stable” setting in the driver panel helps - drops and other issues are less frequent. Not perfect but it doesn’t get in the way as much.

I’m sure i have found the problem with mine, though i haven’t tested it yet since I haven’t got replacements for it.

It was my 8x2 GB RAM sticks running in dual channel was an issue. Running with only a single 8GB stick on my motherboard solved most of my problems, however it still comes and goes but very rarely. Did some digging on this and apparently my RAM sticks weren’t in the ‘Qualified Vendors List’ for my motherboard. With the nature of AMD cpus sensitive on what RAM they receive i’m quite certain it’s the reason why.

Happy to say my unit isn’t defective, just my researching abilities for my PC.

Hope u find your solution

Hello, since windows 11 last build, I do have issues with my UR22, the device is no more recognized by my different laptops (Dell Latitude 9430 and XPS 15 9500). I’ve tried several set ups, though the monitor hub, through a docking station, directly on the laptop… still have the issue. from the device manager view, it seems that an USB is not working correctly, I ve updated the driver from the chipset… weird thing, when not connected, I don’t have any issue with USB drivers… this leads me to few things, there might have something with win11 audio drivers conflits… any thoughts or know issues?
thanks in advance,
nb : I’ve tried USB B to usb C and USB to USB A cable… same issues