UR12 power supply issues

The device has been working great for a month since i bought it. Today the device lost it connection to my PC just for no reason. Usb light started to constantly flash which i believe means it couldn’t get enough power. Tried everything suggested in similar topics on this forum, nothing worked.

Then the USB indicator stopped flashing or glowing at all, either when i connect it trough 5v DC cable to PC usb port, either when i connect it through the regular USB cable. BUT it seems to be working if i set the power switch to 5v DC and connect it with both cables to my PC simultaneously. It seems, there are issues with power management which i do not fully understand. Like it for some reason “needs” to be powered by 5v DC, from now on only taking data signal from the USB port, no longer taking any power from it.

  1. Is my current setup gonna kill the device eventually?
  2. What happened and why it happened, and what can I do to make it work like it should and did before?
  3. Is it a warranty case?

It could be a bad USB cable but if not, probably the UR itself.

I disconnected it from my PC via bottom menu on windows Eject “Steinberg UR12”. Then switched the device back to USB power supply mode with the switch, it’s suddenly working as it should again, with a single USB cable.

Eh. Somehow I’m sure it’s gonna keep on lagging. Sad.

That sort of sounds like the computer is powering off the USB port or just a bad USB card. Have you tried a different cable and UsB port? Perhaps try it on a different computer altogether. If it still has issues, then it is likely the uR itself.

UPD

It’s been working alright since recent days. now experiencing some other issues with power management via usb. while recording on mic with phantom power on, the LED’s (all of them) start to flicker for seemingly no reason and the connection to pc is lost. then i turn the knobs to 0, disconnect phantom power, walk around, touch some cables, unsure what to do, device chills out and works alright again. the same story happened 3 times for now. bad cables, bad usb device, ur12 issue? i don’t know.