UR22-C New Firmware 1.5 Update Failure (and FIX) - PLEASE READ

I tried updating my UR22C to the latest V1.5 firmware today. I’m running Windows 10 (version 1909 / x64).

I followed the instructions in the enclosed UpdateGuide.pdf to the letter. Rebooted machine, only UR22C conected, connected to AC, sleep mode disabled… ran UR-C_firmware_V150.exe. The software correctly detected boot version 1,00 and indicated an update to main from 1.01 to 1.5. All good! So I clicked “Start”.

The lights started flashing and the firmware update began, then I received a message stating that the firmware update had failed and the two red lights started flashing alternately on the device.

Rebooting the device didn’t help. Red lights still flashing.


Tried the procedure again. No difference.

I thought the device was bricked. But I managed to fix it.
Here’s how.

The problem is instruction line 3 of the instructions in UpdateGuide.pdf which reads “Double-click the file “UR-C_firmware_Vxxx.exe” for Windows or “URC_firmware_Vxxx.app” for Mac”. THIS IS WRONG!.

Instead, alternate-click the file UR-C_firmware_V150.exe and click “Run as Administrator”. You’ll probably get a user account warning asking if you really want to run this as an administrator. Yes, you do. The program will run and should detect the UR22C. Clicking the “start” button should complete the firmware update successfully now.

I’ve now got the steady white “USB connected” light on in front of me. Phew.

I hope this post saves someone from ruining their underpants. I also hope Steinberg admins / engineers can check the veracity of this post and update their firmware installer to require Administrator privilege escalation on startup. It might save them both reputation and good will.

All the best


HI !

Same problem here , thanks for your instructions but don’t work on my UR22C.

trying updating 3 times as you said but keeps alternate flashing.

I need help to solve this …

thanks !

Are you definitely running the updater as an administrator? About all I can suggest is disconnecting the UR22C, rebooting your PC, re-connecting the UR22C and trying again

Yes , I’ve done that you said but don’t work …still flashing .
thanks anyway …

1 Like

This same here… Fail.

As @mattster wrote we need to run it in administrator mode.

I took out all of USB devices, even mouse and plugged it into USB 2.0 port.
And it “worked” - The light is now stable, white and is working nevertheless the final communicate was: Fail… Ok Fail, but the device is safe, it is working, miracle.
2 of my USB 3 ports was burned by Line 6 GX. Explaining in details, the interface up to 2.0 is not working any more on 2 ports with my USB 3.0. Exactly while trying to upgrade Line 6. Because of that I was looking for audio interface run on USB 3+ (For that is perfect, latency on windows is other topic).
So for your well being - firmware upgrade only on USB 2.0.

I would like that Yamaha will also include this into the installation guide.

Best Regards

1 Like

Exact symptoms here , now works …thanks man !

1 Like

Also over here. Unable to update… all usb devices disconnected, run as administrator…(got an asus x99-e mobo, this got 1 old school ps2, so connected a ps2 keyboard)…Tried it via usb3 or usb 3.1, nothing, what ever I do I got the message “UR is not detected”…

Hi Fred_Wester,
Have you tried running the firmware update as administrator?

read my comment again…I did… But I’ve got my ur24c updated… A friend of my uses a apple pc, we connected the ur to his apple and did run the update for the apple version… I’m on win 10, and what I do the update tool does not work

Sorry, must’ve missed that late at night. Mine failed on an Asus laptop but worked when then run as admin; now I’m wondering if certain mainboard chipsets might have some sort of compatibility issue. Glad you’re back in business anyway :slightly_smiling_face::+1:

After reading this I thought well should I try to update DSP, firmware and new driver on my Win 10 laptop? I downloaded the applicable files and extracted them and read the installation instruction about double clicking the exe. file which were different to what was in the software. It just had an install icon which is probably the exe. file anyway. You have to be logged in as administrator which is what Cubase runs on anyway and have the interface (ur22c) in my case unplugged.
The software installed no problems so then I plugged in interface and checked to see if the interface was showing in windows which it was and the white light was on.
I then installed the firmware with interface plugged in and two red lights started flashing and it eventually installed and I got the white light on again. I then preceded to load the latest driver which also loaded no problem. I am glad it all worked ok.
I must admit I have had no problems with the updating my 10.5 AI to Elements 11 using the installer software which worked brilliantly.

Mine stopped during the first update after following the instructions to the letter

Swapping to a USB-A port in my motherboard and running as admin fixed for me