UR22 has suddenly stopped working

Hi, I read through a few pages of UR22 related posts but nothing really described this situation.

I bought a UR22 to record from a couple of condenser mics and occasionally a DI guitar and it has been working perfectly for a few weeks. Until today I only had the one XLR lead and only one mic plugged in. I was recording with both for about an hour when between takes the sound dropped out and the power light began flashing as the device kept trying to connect before being unpowered.

I unplugged the microphones, turned off the phantom power and set all dials to 0 and both peak lights remained lit. Testing in this state (after changing the dials) shows no sound goes in or out, there is no direct monitoring on the jack’s or the XLR’s. Turning the phantom power back on just causes the usb light to flash again.

So far I have re-installed the drivers from the disk and the updated ones online, restarted my computer, checked USB suspend settings and made sure it was the only thing plugged in.

I hope that is enough information to go on, let me know if you need anything else. My usual guess is it’s a driver issue but that wouldn’t really explain why it’s worked fine up until now. It feels more like a hardware problem but I’m not really the best person to ask, you are.

Thanks,
Brennan

Sounds like a hardware issue to me. Take the unit back to the place you bought it and have it checked and if necessary, replaced. Otherwise, I suggest you go into your “My Steinberg” account and fill out a support request form and send it. :wink:

Inevitably it was an online purchase, I have now sent off a support request form and am hoping for the best, thanks for your help.

I have the exact same problem.

Did you manage to solve it?

I’m also having the same problem: Was working fine, had just recorded a guitar track. Plugged the microphone line in, then now no sound coming from either the line out or headphones, either on the track i had just recorded or the tracks I had previously recorded without a problem. When i turn on the phantom power it makes a pulsing “blip” noise. Have reinstalled the drivers and inputs, rebooted everything, still no sound. Was thinking about upgrading to the UR44 unit anyway but still. UR22 still under warranty but rather not wait weeks for a replacement. I am very sad -_-

I am having the exact same problem! I do not think it’s a hardware issue, because I just returned mine to Guitar Center and exchanged it for a new one, and I am having the exact same problem right off the bat with the new one too. :cry:

Please help, I have the same issue. I bought my ur22 in the US and I live in Argentina. It’s a long way so I need to know if there’s a solution to this problem I could do on my own. Thanks in advance.

I think this is related to connecting external components while Phantom Power is activated. Please see page 7 in the manual:

Always turn phantom power OFF when it is not required.When using phantom power, observe the following to prevent noise and possible damage to UR22 or connected equipment.
•When connecting devices not requiring phantom power to the [MIC/LINE 1/2] jacks, make sure to turn phantom power OFF.
•Do not connect or disconnect any devices while phantom power is turned ON.
• Set all output level controls to minimum when turning phantom power ON or OFF.
<<<

In this case, it looks like the UR22 needs to be sent in for a repair.
Please check with your local distributor on how to do that:
http://www.steinberg.net/en/company/distributors.html

This happened when I connected my condenser microphone with phantom power, I did not connect any other thing to it. I had it for a week for gods sake. I knew I should’ve gotten a Mackie.

I have the exact same problem. :frowning:

I have tried to use my just purchased UR22 but I’m having the exact same problem and I don’t know what to do. I have tried to install different versions of the driver to see if one of them works, but there’s still no change. I have also changed the USB cable. At first, the peak lights would stay off, but a few minutes later they turned on once again. I can’t use the phantom power because the interface gets disconnected and it does not record a sound. I have bought it in USA, and I’m trying to use it back in my country, Argentina, but the UR22 is unresponsive. Please tell me if you know what I could do.

Usually, you would have to contact the dealer you bought the interface at. If that is impossible, you could contact Yamaha in Buenos Aires:
Yamaha Music Latin America S.A.
Olga Cossettini 1553 - 4°
1107 Buenos Aires
Argentina
54-11-4119-7000
infosteinberg(at)yamaha.com.ar

They should be able to repair the device but because of the purchase in a different country it might not be free of charge.

Same problem here. I connected a condenser microphone with phantom power, and poof… Gone, white light blinking and a popping sound from the speakers. I switched Phantom Power off, tried other USB cables, updated the driver, nothing works. The device is not working anymore. This is CLEARLY a design error.

And just 2 weeks out of warrenty. What a crap device!! Never again.