UR22 mkII only shows up as "output device"

I’m using Cubasis 3.2.1 with my Huawai MediaPad T5.
I connected everything as shown on the Steinberg homepage.
When going to the audio settings in Cubasis the Interface (UR22 mkII) shows up as an output device on the left side. It unfortunalety doesn’t appear under the “input devices”. There’s only the “built-in microphone” as an option.
Any ideas out there? Would arpreciate every single hint…
Thanks und best regards

Have you gone into Android settings and enabled “OTG storage”?

Thanks for your reply! There’s no OTG related option in my android settings… But I tried an OTG checker app and it says that the tablet supports it…

Does searching the settings for “OTG” yield anything? I seem to recall it can be labelled a bit differently across the versions.
USB OTG Checker can also be installed to verify whether it is available and enabled - https://play.google.com/store/apps/details?id=com.faitaujapon.otg
Failing that, try the official Huwawei OTG cable for your device - they shouldn’t be expensive. An OTG cable is not the same as a regular USB cable. If still no joy, it might just be that this device is incompatible…

While you’re at it, invest in a few adapters: USB-A to USB-C, USB-A to micro-USB. Like these:

Such adapters are cheap and can be very, very useful when trying to connect MIDI devices to Android devices. Worth getting regardless.

Hope you can get it working.