UR22 no MIDI device recognized

Hi,

I just received a replacement UR22 device and I am not getting any MIDI device recognized in Windows when I plug it in (Audio is fine). I am running Windows 10 Tech Prev which I understand is probably not currently officially supported but it was working flawlessly before. The only thing I did before plugging it in was updating to the latest (1.9) USB drivers. I have also tried downgrading to 1.7 again but to no avail. Any suggestions on how to troubleshoot would be most welcome!

Casper.

I have the exact same problem.

I changed from M-audio 2496 PCI card, which was working without problem, MIDI interface etc.
And now when having installed UR22 I don’t have any MIDI-in anymore.

I’m using Windows 7 X64 SP1 latest updates and I have tried both drivers just as budtz mentions.

I have tried both Cubase AI8 and Synthogy Ivory Standalone program, none of them displays any MIDI devices for me to use.

I have even tried reinstalling windows. Please, any help would be very welcome.

I found a solution to my problem.

AT the same time as changing soundcard from Maudio to Steinberg, I changed my setup to use Remote Desktop (RDP). I’m not going into the details in my setup, but RDP was the problem.

The solutions was two.

One:
Don’t use RDP.

Two (the better one):
When connecting to the computer with RDP, do the following before connecting.
Show Options -> Local Resources -> Remote Audio -> Settings -> Play on remote computer
Voila, all audio devices including MIDI should now be visible through RDP

I tried using the Steinberg support, but I must say that the Steinberg support is a total joke. It took them 30 days to answer my request, and by then I had spent a great deal of my private time to solve this by myself.