UR22 NOT WORKING; Loud, Pulsing blip/pop when 48v turned on

I have been using my UR 22 for a couple months now. However, today I was recording with a condenser mic with an XLR cord that had been sitting idle and coiled on a couch in my studio, and this particular time the XLR cord was very sensitive for some reason, making a lot of noise and even more so when it was touched. When I tried to free the cord of kinks in an attempt to somehow fix the input would occasionally make an “ear-popping” sound as if it was being unplugged, momentarily stop working, and then return to monitoring. I was being very gentle with the cord, however in one instance when I picked it up the input popped out for good, my DAW indicated an error with connection to the interface, and the loud “ear popping” blipping (whatever you want to call it) started repeating, a bit faster than once per second. After unplugging the input and closing down the DAW I found out the only way to stop the noise was to turn off the phantom power. Now, every time I turn the phantom power on the pulsing blipping occurs. Also my monitors no longer work through the Steinberg, so I’m concluding that the thing is broken.

I noticed at least a few other people had this problem, so if ANYBODY can help me get this thing working that would be amazing. If it really is just broken, what can I do to service it? I’m having a super difficult time navigating the support page and I have finals to study for :frowning: :frowning: . I’ve purchased it new within the last 6 months, and I live in the US.

Please help if you can!


I got the same problem today. Unit is NOT working - probably something with the Phantom power - this is so f…ked up.

Happening to me as well… just started today… UR22.
Anybody have a fix or is this thing dead???

Hi guys,

I’m having the same issue, has anyone come up with a solution?

It looks like, the devices need to be repaired. Please contact your local dealer or support for details on how to proceed.

Hi everybody,

Same issue with my 4 month old UR22.
It’ doesn’t work anymore after using the 48v for the the first time

Same here.

When phantom power is turned on, I hear a pop-pop-pop through my headphones, and the white usb led blinks and the device disappears from windows.

If I turn the phantom off, the device pops back up in windows and the led goes on solid like normal, but there’s still no sound through my headphones.

Seems like something bad happened to the internal power supply.

Hi all!
I faced the same problems with my “ur 22”. Who knows how can I make it right?

I know it’s been a long time, for anyone that researches this… try a new USB 2.0 cable. That is what fixed my problem.