UR22 Stereo in - mono out?

Hi,
I recently bought a UR22. It seemed perfect for me. I have a digital piano that I want to connect as discribed in the UR22 operations manual page 10. I got the impression that the two audio inputs on the front would work together as a stereo line in. - My experience now is that this is only partly true.
When I record the piano connected to the front inputs into my DAW through a USB cable, I get a stereo signal, true to the piano output signal.
But when I listen to the piano directly when playing through the phones output on the UR22 front, I get a mono signal. NOT true to the piano output. And it is the same thing with the line output on the back.
To me this is a serious drawback. Am I doing anything wrong here? Or is this the way this audio card works?
I have tried to solve the problem by connecting an external mixer to the UR22 inputs and outputs, and not letting the monitoring signal go into the UR22 but then I get acoustic feedback problems if I don’t watch out.

Direct monitoring through UR22 is always mono. Imagine when you are monitoring one channel and you get the sound from left speaker only, it’s weird. Some audio interfaces that have a software mixer will have the ability to control which channel to monitor and usually can also map channels to left or right speaker, but UR22 does not have one.

Thanks Miller for confirming my experiences; - I am not crazy… So, I guess I’ll just have to live with the mono signal. And look for a mono/stereo switch on my next audiocard. It didn’t say anything in the manual. Hmm…

Your problem can be easily solved by software monitoring (which is more useful in most cases). You can turn the Mix knob on the UR22 to 100% DAW, it lets you monitor only the output from your DAW, and then setup your DAW to output signals when recording. It’ll get excellent result if the ASIO latency is low enough. Try setting UR22’s ASIO buffer to 64 first and see if the sound stutters, if it does not stutter, play with that setting, otherwise change the buffer a bit larger and test again until you find the smallest buffer that does not stutter the sound in your setup.

Yes, I have tried your suggestions, and it works alright. But it is still not the same as listening directly to the piano output. Somewhere something is degraded in the signal. But it is no big deal, really. Maybe I’m just being picky. -But setting the buffer to 64 samples actually works. I’m a bit impressed. I recently upgraded my computer with a new motherboard and an i7-CPU. It was well worth the money.

And that’s why Steinberg had to provide the choice! Something that is weird for one category (vocal, guitar etc.) is a must for another category. I was shocked, when discovered, that Steinberg didn’t give this obvious and a must control! Look at competitors. They offer dedicated selector like Mono | Stereo | Off. Steinberg UR22 (mkII) doesn’t have anything like this and have only MONO mode for Direct Monitoring. How come? Or maybe Steinberg don’t care about keyboardists? This is ridiculous and the only enough reason, why I immediately stopped to consider this audio interface. Big mistake from Steinberg. I hope something new in this class from Steinberg will fix this failing. And the sooner the better.

What cables are you using to connect it to the front inputs ? I am looking to connect my a phono preamp to my UR 22 MK 2 .

Most keyboards have line out plus headphone out. Cant you just monitor via the keyboards headphone out?

I followed your advice to “hasseg001” (thanks for that) because I also had been wondering about hearing only mono while making copies from a DAT-Player to Samplitude Pro X4. The Software and UR22mkII I bought only recently and didn´t notice yet the dropdown box like shown on my screenshot. After choosing “Software Monitoring” I heard the source in stereo.
UR22_Software_Monitoring.JPG