UR22C 2.0.0 Firmware Update Failed

I downloaded the new 2.0.0 firmware update and launched the dspMixFx program to update. When the app launched it prompted me to do the firmware update automatically. I clicked to begin the update and immediately got the Windows blue screen and my computer restarted. Now my UR22C input peak lights are flashing back and forth and will not stop.

Please help,
-Greg

1 Like

Hi Greg
I’ve the samle problem with my UR24C interface.
Could you solve this problem?
Thanks.
Greets
Peter

Hi Peter, somewhere on this forum it was suggested to switch the UR22C from a USB 3.0 port to a 2.0 port for the update. I did that and it solved my issue. Afterwards I plugged it back into the 3.0 port. I hope this helps you as well.

-Greg

Hi Greg,
thanks for your answer.
I’ve tested on different USB ports, 2.0 and 3.0, but without any success.
I’ll write a mail to the Steinberg support. Hope they can help.
Greets
Peter

Any luck with your firmware update Peter?

Thanks, Greg,
no, unfortunately not, I wrote different mails to the Steinberg Support, but the didn’t answered until now.

I’d like to add my UR816C to this thread:

Same issue with TOOLS Version 2.0.0.: clicked on ‘Ok’ as dspMixFx adviced me to do at startup, firmware update started and almost immediately aborted with an error.
Now I have the same flashing lights back and forth.

I already opened an Support-Ticket back in Mai 12th - almost a month ago.
No reply so far. Not a single word from Steinberg.

Steinberg Support finally responded to my ticket from Mai:

They want me to try again connecting my device to a USB2-Port instead of a USB3 an restart dspMixFX as Admin, which I already tried before on two different PC’s and a older Laptop, but now, unlike back then, it worked!

So my issue is fixed.

Maybe the interface needed a few weeks of rest in the shelf xD.

Disconnect, restart computer and try again.

1 Like

Many thanks @Muk888, that worked.