UR22C audio dropout problem

Still the old problem, I tried every solution but nothing helps.

First of all, I tried each USB port on my laptop, even tried to connect with a C to C cable, but nothing changed;
then, re-installed the driver, and followed the manual, nothing changed;
edited USB 3.0/2.0 set, buffer size, didn’t solve the problem;
plugged a 5V DC power;
updated USB driver, updated UR22C driver… I did everything I could but they work as they used to.

Something funny also happened: I used my dad’s low-performance Windows 10 PC, and it works very well even I set it to 192khz, with no stutter, no error, and everything seemed perfect.

I’m pain at that time, and viewed some discussions in this forum, somebody said it works after disabling AMD in-core GPU, it may help a bit but the UR22C still not works properly.
I guess it may be a CPU-caused bug, and I don’t think it occurred to the USB port or anything else. I played CPU Furmark but the problem’s not reduced or getting more stutters. Maybe it’s a PCIe problem?

Feeling helpless, wish the Steinberg software team give us some help, or I could just buy another one instead of UR22C.

Here’s my environment:
Windows 11 Pro runs with all up-to-date drivers
Additional plugged GPW and a Razer keyboard
ROG Strix Scar 17 2023(G733PZ) that just bought for a month

  • AMD R9-7945HX with Radeon 610M(disabled)
  • RTX 4080 Mobile GPU
  • 4800Mhz 8G*2 DDR5 RAM

Below Written at 8/6/2023 21:05PM(GMT+8)
The stutter can still re-show till I ran CPU FurMark. There’s much less dropouts when I was running the CPU FurMark. I’m so confused.

try buddy what i was posted in my thread:

device manager > sound video and game controller > and here turn off all things like Realtek High def audio, nvidia virtual audio device (wave extensible)(WDM), nvidia high def audio, nvidia broadcast, etc etc (PPM > turn off device)

for me it work by 2 days now we will see

I tried the solution that turns off any other audio drivers except the Steinberg driver, it works for a little while but started dropouts later
Feeling helpless, I turned to the reseller for a refund and bought a Focusrite 2i2 instead.

let me know if changing the interface solved the problem