ur22c USB error

The new ur22c does not work in the new ASUS proart studiobook w700G (with windows 10 64bit 1909 installed).
It said audio interruption due to USB error is detected. However, the laptop is new and powerful. I cannot imagine what conflict with the ur22c driver.
Can anybody give some suggestions?
2020-03-22 (1).jpg

I have the same problem. I have a new ASUS VivoBook laptop with windows 10. I have a ur22 which i have used with an older desktop for years and it worked fine.FDid you come up with any info on the problem?

I am having this same problem, it seems I have fixed it, but not perfectly by using the 5v DC power source instead of usb power. But it still seems to come a little bit but not as much as before, I’d love to know a real solution to this

Good luck finding a solution. I had a USB error message after a dropout.
No messages now but generally still have audio/connection dropouts on an Acer i5.
Should not be happening and it looks like we’re on our own.

I had the error since upgrading to Win 10 with the original UR22. When playing a video or Youtube clip, the video and audio both stutter and pause, with mostly garble coming though from time to time. Not to mention it just does not work with my DAW (Cubase).

I’ve had the UR22 for over 10 years and has worked perfectly (Win 2000 ME - Win 7) until the upgrade in OS. I thought it was an error in the UR22 USB interface internally, as I couldn’t find anything online at the time. The audio still worked, just needed to route audio from my monitor to the inputs, but this means cannot records an playback at same time unless monitoring using headphones.

Recently I bought a UR22c thinking it would fix the issue with new drivers and hardware. Still the same error, and found it’s the same driver as the UR22 and other models. Driver is up to date and I have tried turning on XCHI, changing to USB2 connector in the MB, among other isolation tests. I also tried connecting 5v power as suggested in this thread, but this has had no change at all for me.

This is so frustrating, hopefully Steinberg/Yamaha can address this, if they read this thread. If you work out a solution, please post :slight_smile:

I’ve had a new UR22c on W10 for about three weeks and have had dropouts on playback with VI’s. Also usb light would occasionally blink. Have spent that time trying to sort it with posts and support ticket.
No reply to the ticket but someone from Steinberg advised that it’s due to improper device connection.
Makes sense. I’ve connected the supplied usb 3.0 lead, what more can I do?
I mentioned this is another post but I cleaned the plugs with electrical cleaner and the usb light stays on and now works as it should.
Just one solution that worked here out of many others that people are trying.

Try a different computer. Just for troubleshooting.
It sounds like a USB controller issue. Check for updated USB controller drivers.

@jaslan - USB controller drivers are showing as up to date when updating in device manager, and windows update doesn’t find anything either. I also ran DPC checks and the system is not showing any major problems with real time processing when under stress, even when audio and video is stuttering and pausing like crazy with the system almost idle. Used Latency Mon and DPC Latency Checker for this.

Don’t get me wrong, I greatly appreciate the effort to help us. I have tried disabling GPU drivers, even removed them all, and then took the GPU out in-case it was PCIe locking up the CPU. Can you think of anything else to try?

Thanks,
Bio

Hey, I’ve been using the UR22c for a year now, on both Mac (mini 2018) and Windows (dell Inspiron E 5770 with two GPUS: Radeon 530 GPU and Intel UHD Graphics 620).

I had disabled the Radeon GPU (Hardware manager -> Radeon 530 -> disable) as it had errors with Microsoft Flight Simulator 2020 (the internal UHD Intel ran it without problems).

As I uninstalled FS2020 yesterday, I re-enabled the Radeon again, then the dropouts started ("USB Error Message etc).

However, I also did a complete update of the bios (including USB ports) and other drivers.
This is, why I thought, one of the (un-downgradable) USB-port updates was responsible.
Today, I downgraded the system bios, but the problem remained the same.

As the soundcard kept on working fine on Mac (BigSur), I could say, that it was not defective.

Also this didn’t change anything:

  • connecting with another cable
  • connecting with an additional power-source and enabling “micro-usb-5V”

However, now, disabling the Radeon GPU solved the problem.

Have fun.

I have a Radeon R5 230 Graphics card and never had any problems with audio dropouts (UR816C and a second FW interface).
Only the one time before the Radeon when I tired a NVIDIA card.
Older PC(2012) and just as old Bios, never been updated. I guess it is the whole package somewhere that does or not give audio problems

Hello!

I’ve been busting my head with this usb interuption thing for a week, I’ve tried almost everything and I’ve found a solution, so I hope this will help some of you.

In my case, it was the motherboard or maybe the usb connections on it. I’ve got a new motherboard and now I get no errors, everything is working perfectly.

Hope this helps, good luck!