UR22C. Yamaha driver "Device could not be opened"

Hi! I’m new to this all stuff, I searched for answers for this topic but nothing was exactly the same as the problem I have.
I’m trying to use my new UR22C. Downloaded, installed and activated Cubase AI 10.5. Installed the drivers YSUSB_V1104_win. Opened Cubase.

I go to studio setup-VST audio system- I select yamaha steinberg USB ASIO- asks me if I want to switch and I click yes- then it says “device could not be opened”

The UR22C is connected and detected by the PC, an USB led is ON.
So I’m stuck, I don’t know what to try. Uninstalled and installed drivers a few times, tried different USB ports but I really don’t know what to do.
Would really apreciate some help.

My PC is:
Asus ROG Strix G531GT-BQ012 (G531 Series)
Processor: Intel Core i7-9750H (Intel Core i7)
Graphics adapter: NVIDIA GeForce GTX 1650 Mobile
Memory: 16384 MB
Storage: 512 GB SSD
Connections: 3 USB 3.1 Gen2, 1 HDMI
Operating System: Microsoft Windows 10 pro 64 Bit


Please install the very latest driver version.

Okey, now I have solved that. Looks like the driver I was using was compatible with UR22 but not with UR22C.
Now the interface and cubase seem to know each other but I still get no sound out of cubase. I can listen to music outside cubase for example so I know it’s something in cubase configuration


Make sure UR22C is selected as an ASIO driver. Make sure proper output is selected in the Audio Connections > Outputs, please.

I am getting the “device cannot be opened” message as well when I try to switch to yamaha steinberg usb ASIO in the cubase studio setup area.

It was working fine until I updated to the V2.0.3 driver.

Any ideas?


Could you try to connect your device to other USB port, please?