UR242 MIDI In/Out not working


I’ve tried many things already so I’ll try to be as thorough as possible.
I’m running Windows 7 64 bits.
I’m using Pro Tools 11 (up to date) and my Yamaha drivers are up to date too.
I’d like to plug my Roland TD6V in my UR242’s MIDI port to try out software like EZ Drummer etc… The problem is, nothing will register, no matter what I try.
I’ve checked my MIDI cable by plugging the TD6V to a Yamaha PSR225 keyboard, both in and out worked so I know it comes neither from the cable, nor from the In/Out ports of the drumset (by the way, the keyboard won’t work either if I try plugging it in the UR242).
I have an M-Audio Uno MIDI Interface, which if I use it for either the drumset or the keyboard, will work both ways, so I know I’m not completely messing up the software setup.
The UR242’s MIDI ports (both in or out) will show as “Steinberg UR242-1 [Emulated]” in the MIDI studio configuration tab, is it normal? I mean, the M-Audio interface shows the input as “MIDISPORT Uno In” and the output as “MIDISPORT Uno Out” so I figured there might be something wrong with the UR242’s MIDI ports not being recognized properly…?

I’m not completely desperate since I can either plug in directly with the audio outputs of the drumset, or I could use the M-Audio thingy if I really want to go for MIDI, but I find weird the UR242 MIDI ports won’t work since I haven’t had any problems whatsoever with the device so far. Especially since I’ve browsed many forum posts now, and pretty much nobody has this kind of problem as of what I could find.

If I forgot any valuable information, please ask away, I’ll be stalking this thread because I hate not understanding why stuff won’t work. :smiley:
Cheers, ChaosPotato

The “emulated” bit doesn’t seem normal to me. I have a UR44 and it just shows up as Steinberg UR44 - 1. Have you tried plugging the UR into a different USB port? The only other thing I can think of is that if you are not on Win 7 SP1, then website does specify a different firmware/software.

I did a google search of “windows 7 emulated midi” and found several thread that discuss problems in PT with this. I briefly read through and it appears it may only be a PT issue. HTH

Hey! Thanks for the reply!
I tried switching USB ports, no better. The Midisport Uno does work in the port where the UR used to be though.
I double checked and I am indeed running W7 SP1 too. I’m gonna dig around using your search terms, I was convinced it had more to do with Pro Tools or the UR than Windows 7 itself… Thanks again!

Update : after reading quite a lot of forum threads, it seems so random that I think I’m gonna give up on using the UR’s MIDI ports on PT11. I’ll stick to the MIDISport Uno for Pro Tools and I’ll try the UR on the standalone version of EZ Drummer 2. Many thanks for your reply again Jaslan!