UR242 No direct monitoring sound, like before PC change

Hi all

I use a Steinberg UR242 and Cubase elements 10.
I was using this setup on Win10.
I always heard the direct monitoring of my audio interface input. Even when no “monitoring” was activated on Cubase tracks. The direct sound was always here, and I worked with that. I never touched the “monitoring” buttons, because I never played with effects. The dry tone was everything I wanted;

Now I changed CPU and motherboard, still on Windows 10, everything is reinstalled, latest drivers for UR242 and last Cubase 10 elements update.
BUT when I launch cubase, the direct sound of my audio interface is cut. Cubase takes control of that. It never did that before the hardware change.
So now I have to engage the monitoring button on a dedicated track to hear my direct sound. And i have to disengage it to play the recorded track.

Before that, I could play the recorded track, and in the same time I could hear the direct sound.

How could I go back to my previous way of working ?

I could join screen capture of anything

Turn off direct monitoring in Cubase.

Hello,

direct monitoring is already turned off ! I tried with and without.
Of course without I have more latency, when I click on the monitor button of the chosen track.
And with direct moniroting activated, I have no latency when I click on the monitor button of the chosen track.

But I still have to click on this monitor button of the chosen track ! I did not do that in two years before the hardware change ! Even without this yellow monitor button activated, I had the direct sound from my interface straight to the headphone, combined with the cubase output !

When using other softwares like Audacity, I have the direct monitoring, like I was used to.

And when using Audacity + the Dsp Mix app of the UR242, I can blend and mix to my tastes the DAW (audacity) output + the direct input, to my headphones.

With Cubase, the Dsp Mix app can’t work, since Cubase takes the lead to control the interface. And I am stucked !


cubase 10.0.60 build 396
yamaha steinberg drive 2.0.4

What makes you think that? DSP-Mix-FX app is integrated into Cubase, once installed you should be able to control the UR242 from inside Cubase… and you can use DSP-Mix-FX at the same time
You should turn direct monitoring on… for latency free monitoring…

Hi,
Indeed when I turn direct monitoring on, THEN when I click on the yellow monitor button for a track, I have the direct monitoring to the headphones.

But I don’t want to use moniroting that way.

This way of working is the 3d way described on this video : https://youtu.be/UJcpLXKI-HU?t=359

I want to work with the 2nd way, called “Direct monitoring Off, Monitor Button Off” which begins at 6min on the video. It is simply the input of the interface soundcard routed to the headphones

I worked with that way for 2 years before hardware change.

A screen capture when I use audacity :

We see my input signal, and the Daw output signal. Both go to my headphones. (I played on direct while Audacity was playing the test track I just recorded, both sounds were audible)

But when using Cubase, the only "Dsp Mix " thing I find is here, that graphical inetrface :


And I don’t know how to configure the input signal to go direct through headphones, like it does in Audacity.
Maybe there is a secret Dsp Mix pannel that I didn’t find on Cubase

The UR242 has no hardware monitor switch or dial, so you have to use dspMixFx to enable direct monitoring or give the control to a DAW (like Cubase) that can use DM, Audacity can’t do that…

Did you tried to click on the hardware controls?

Hi,
I’d like to use the dspMixFx to enable direct monitoring with Cubase. But I can’t find the function that allows me to blend direct with DAW output to headphones, unlinke what appears on the dspMixFx app. I guess this function should be somewhere in Cubase right ?

where is the hardware control ?
I have this when clicking to studio => Audio hardware setup

capture cubase 4
capture cubase 5

in your picture above…
there is hardware written on the mixer panel… could be a hint?

What happens when you click on the controls?

Indeed this HARDWARE button opens the graphic pannel, which appears just under it, on my screen capture.
From this schematic pannel, we can control highpass, phase inversion, Fx and reverb, etc .

All the functions that are also present on the dedicated DspMixFx app , but on a different display

BUT still no way to blend the direct monitor signal !

Sorry, my UR22 has no dspMixFx capabilities… can’t try it on my side…

A workaround could be to set Cubase to release the driver when in background, maybe you could be able to open dspMixFX at the same time…

grafik
what happens when you click there?

set Cubase to release the driver when in background doesn’t allow me neither to use the dspMixFx !

This “dm” is not a clickable button, but indicates where does the signal came from when using the cubase “direct monitoring” option (so, when also activating the monitor button on a specific track, not what I want).

I can change the fx integrated to the interface soundcard.
On my previous screen capture, no Fx were present on the signal

On this following screen capture, the Fx are activated, but only for the direct monitoring. ( again, the Cubase direct monitoring one, not the one I want and I used to use )
CAPTURE CUBASE 6

On this following screen capture, the Fx are activated for both the direct monitoring and to the Cubase signal path
CAPTURE CUBASE 7

I guess to try to retrieve the same conditions than before my hardware change, I will have to downgrade the Cubase and Yamaha Steinberg driver versions.
Too bad I didn’t write them somewhere, don’t know which they were !

ahhh… there is only one direct monitoring…
the interface does it… Cubase just does the control of it… it remote controls the mixer in the interface

the app dspMixFX does the same…

Did you ever tried to use dspMixFX and Cubase at the same time?

Yes , when cubase is open, I can’t start DspMixFx, which says the USB control is used by another app.

Strange that I used UR242 and Cubase10 for two years with the way I described on the first post. I never activated any “monitor” track button or "Direct monitoring " inside Cubase, nor used the DspMixFx

The always on monitoring from the UR242 was just here by default, the same way for Audacity or Cubase

You can get it to work as you want, but it would require you to uninstall/delete the mixer extension that is installed into Cubase. And you will lose those hardware controls in Cubase, but you can then open and use dspmix and Cubase at the same time.

1 Like

Ho ok ! Maybe it was this configuration I had before !
Does this extension has a particular name ?

Thank you , it seems to be the exact same topic ! I will try to find that on Windows

It worked :

"for windows OS, locate the ur extension dll (program files/common files/steinberg/shared components) open it with notepad and simply delete all its text and save it (make a copy of the original if u still want to use ur with cubase control later) "

Now I can use the UR 242 DspMixApp independently than Cubase !
I guess when I installed cubase two years ago, with my old PC, I did not installed the software dedicated to my UR242, thus no ur extension dll was present, no monitoring control from cubase. I don’t remenber ever seeing the DspMixApp before.

When I reinstalled everything after my hardware change, I also installed the software dedicated to my UR242 , that was the difference !

My issue is now solved , thank you

1 Like