Ur242 problem

Hello i use UR242 and since i bought it i never got to work with it , my audio cracks or interrupts from daw audio and other apps like youtube , it has an error which says “Audio interruption due to USB error” i tried a lot of solutions like updating the drivers and etc but still i have this problem. Does anybody has this problem and fixed it ?

OS? Computer specs?

Windows 10
16gb ram

I dont know what else to tell you , please helo me

Have you tried running LatencyMon? …

Resplendence Software - LatencyMon: suitability checker for real-time audio and other tasks

Also, it might be worth trying ASIO4ALL just to see if it could be driver related. …

ASIO4ALL Official Home - news and updates

yeah i did all of this and still have the same problem !!! i dont know what to do anymore

What was the result? Can you post a screenshot?

Again, what is the result of your findings? Without details, nobody has a clue how to help you.

You might want to slow down. Start by using upper case letters and punctuation. Proceed from there.

(Okay … maybe a bit harsh. But, seriously, if you want help, provide details :wink: )

For example:

What is “daw audio”? What software are you actually using?

Hi @labinotm9 and welcome to the Cubase forums.

Did you manage to sort out the issues you’re having with the UR242?

Are you using a Laptop or PC?
What Motherboard model are you using?

I use FL studio for recording , my problem has not been solved , i use GIGABYTE

Hi @labinotm9

There are a few things you could try, but don’t hold your breath. You may have tried some or all of these, but just in case…

If you haven’t already, check whether you have the latest UEFI/BIOS for your Motherboard. If you haven’t, then update it

In Windows, under power management, disable “USB Selective Suspend”. Restart the PC. Check if it helps.

Try different USB ports. I would suggest turning the PC off each time, before changing port’s.

Try using a different YAMAHA Driver version. 2.0.3, 2.1.3, 2.1.4, 2.1.5. Uninstall the current version first. Restart the PC after each install/uninstall and try different USB ports with each driver.

Enter your UEFI/BIOS and under the Chipset tab, change XHCI mode to "Manual " (this fixed the issue for me on a Gigabyte Motherboard) and see if this improves anything. XHCI is what tells the Operating System how to use the USB 3.0 ports. Try different ports.

Barring these suggestions, I really couldn’t say. There are a number of people who have reported issues with their UR/C interfaces. It seems driver, system and software related with varying issues. Some have managed to solve the problem by using various tweaks, other’s, not so lucky. You may find someone using the identical system as yours, but not encountering any issues.

Here is a link to Steinbergs guide on optimising a PC for a DAW.


If all else fails, Steinberg recommend a fresh installation of Windows.

Let us know how you get on.
Good luck.

1 Like

I am sorry i have tried everything … still the same problem i dont know what to do anymore i am soooo sad , i cant start producing …

Sorry to hear, none of the solutions have helped you. I do feel your pain.

It does seem like the number of people who have issues with there UR/C interfaces, is very slowly but surely growing. I believe that the YSUSB driver is poorly written. One that is in desperate need of a complete overhaul by Yamaha. It’s far too unpredictable.

But since the majority of people do not experience such issues’, and their products continue to sell, I don’t think they (Yamaha) care too much for the minority.

I do believe there is a way to get the UR242 working as it should, since there are people who have the same / similar specs as yours and are using the UR242 with success.

As a last resort, you could try a fresh installation of Windows and Software. A pain, I know, but if it somehow fixes the issues, then great. If not…

If you feel that the UR242 just isn’t working for you, maybe just try and sell it, and use the proceeds to purchase from elsewhere.

This wasn’t answered, how should we know?

Which one? There are hundreds of Gigabyte boards on the market. Chipset? Board name?
The drivers for your specific board are installed?

I doubt that.

1 Like

Hi st10ss.

Could be a H410M, H510M, B560M or a H470M. Granted, there are different iterations’ of the H410M and the H510M, but unless there is a known issue with one of these Gigabyte Motherboards (12 in Total) with the UR242 YSUSB driver, I didn’t see the need to query this.

I queried the Motherboard because I have a Gigabytes Motherboard, and the only thing that gets the UR824’s Driver to function as it should, is changing the XHCI mode in the UEFI/BIOS. No other OS or UEFI tweaks needed.

The OP has tried everything he can think of, or has been advised so far (hopefully). But if you know of any issues with the boards mentioned, and the YSUSB driver, with or without a fix, I’m sure the OP would be forever grateful, as I was, after reading in the Steinberg forums of the XHCI workaround.

My UR824 was redundant for almost 2 years because of driver issues. During which time I had purchased 3 more Audio Interfaces, three different manufacturers and no driver issues whatsoever and on three different systems.

So I am 100% convinced that the issue is the YSUSB driver with its picky compatibles, since on these three different systems, it just does not work as it should.,but the XHCI workaround, fixed it on one of those systems.

The variables are just too vast, from Motherboard, Graphics, Memory, Dives, OS Settings, it’s crazy.

I already mentioned somewhere on the forum, I had an issue with my UA Apollo USB some years ago.
I changed the graphic hardware (going from the internal graphics to a dedicated Radeon), and the problem was gone. I still use the Radeon on my newer system without any issues.

So it is possible that not all correlations are obvious.

And my UR-22 is just working without issues since years on a different (AMD) system.

1 Like

That’s interesting, the OP could well be using the onboard graphics. Agreed, addressing this, could solve his issues.


This is exactly a point I have been making. The majority of owners of the UR/C interface, do not experience the issues a minority may be having, but still, I believe there are definate issues with the YSUSB driver that may be impossible to remedy. And for new system builds, there will be a minority who will experience issues with their UR/C with no fix found.

I have a total of 6 audio interfaces, but it is solely the YSUSB driver that has ever given me problems to the point of abandonment.


@st10ss has made a pretty valid point here.

If you are using the on boards graphics, it certainly is advisable to invest in a dedicated GPU. Could well be the issue here.

Guys i found that my GPU does the problem , so i rolled back the “DISPLAY ADAPTERS” driver and no issue when i install my GPU drivers the problem came back , how can i make that my GPU doesnt interfiere with my Audio ?
My GPU IS :AMD Radeon R9 380 series.

Well at least, that’s some progress.

A few things that may be helpful.

1.) Make sure to only install the latest AMD Radeon R9 380 driver without the added game related AMD Settings (bloatware).

If that doesn’t work, you could try.

2.) A different PCI-E Slot for the GPU, if your Motherboard has more than one PCI-E Slot that is.

3.) Try Microsofts Generic Display Driver for the R9 380, instead of using the AMD driver and see how that goes.

4.) Have you tried using the Intel HD on-board Graphics at all? While it may be best to use a dedicated GPU, some users have reported no issues using the on-board graphics.

1 Like

I tried step Nr.1 , it didnt work
Step Nr.2 : i cant do that because i dont have any other slot
Step 4: i only have this GPU because its a build PC i cant choose “onboard” if I understood your comment
Step 3 : i dont fully understand how to do that can you explain more ?

That’s the reason we want specs… Which CPU do you have exactly? With all numbers and letters… there are 3 different i5-10400.