UR24C - No Sound on my headphones (Windows 10 / Ableton)

Hello,

I bought the URC24C audio interface a couple of days ago and until this morning it all worked fine. Whenever I wanted to use my headphones, I switched to “Output 1” and turned the fader to input cue, so it would only give me the sound of the headphones. Today it suddenly stopped working and I cannot figure out why. I haven’t changed any settings. The only thing I did, I unplugged my headphones cable over night to see if I can hang them somewhere else. And now there is nothing I can do :/.

Some informations:

My headphones are DT1990Pro. They are working on my phone and I tried using different headphones with the UR24C. I am using Windows 10 and my DAW is Ableton. But it isn’t a DAW issue, since I have the same problems trying to play any audio on Windows.

Since there doesn’t seem to be a way to upload pictures I’ll describe my URC settings when trying to listen to headphones: Outpur 1 (Split) → Mix knob all the way to Input / Cue. Once I move the knob towards DAW / Master, the speaker start playing the music again.

Note: Switching between Output 1 and Output 2 doesn’t seem to change anything.

Am I missing something very obvious? I mean surely the interface didn’t randomly break after a few days of use right? :smiley:

Thanks for any help!