ur28m: how do I stop Clean & FX sound at the same time?

whenever I try to play or record my guitar into my mac thru inputs 1 or 2 I always get my clean guitar sound as well as the fx sound.
I use Guitar rig & Amplitube & Logic and the result is the same with all off them. All I want to hear is the effected sound as I find it off putting.
Is there a way to turn it off so all I am hearing is the effected sound?



I think I’ve just answered my own question
The new Mac Pro’s have no audio input of their own, so the 28M was being used as the default. I solved it by plugging in an old interface and selecting that as the input instead.
It seems the inputs on the 28M are always heard whether they are selected or not.

Hi Shawfing -

Are you using Cubase? If so, maybe check to see whether the little “monitor” signal is colored “yellow” on the clean track. If it is, try clicking it so it is no longer yellow … does that make it so you hear only the FX sound?

Not necessarily, but you need to provide more signal routing details if you want a more definitive answer.

Okay, so I plug my guitar into channel 1 of the 28M, which is plugged into my Mac Pro. I hear my clean guitar sound. If I fire up any Amp Sim, or Logic or whatever, I hear my the clean guitar sound along side whatever FX I have running, not just the effected sound which is all I want if say I 'm using a distorted guitar sound. I don’t want to hear my clean sound as well.

No matter what settings I choose in my audio preferences or in the 28M console software I still hear my clean guitar sound. There doesn’t seem to be any way of turning it off.

i don’t use Cubase so I can’t comment on how it works with that, but this really came to light because I was testing out the new MIDI Guitar software ( which is fab by the way) and wanted to turn off the clean guitar sound and just hear whatever synth sound I was playing. It just doesn’t seem possible to stop the 28M inputs being fed straight to the outputs.

I should also point out that this is a new Mac Pro setup with a new 28M. it didn’t happen with my old Mac & interface, So I am wondering if it’s an issue with the new Mac which doesn’t have a sound input of it’s own & seems to automatically choose the 28M for it’s input.

I hope this is a bit clearer.


Update. I am also hearing my guitar even with the computer turned off, so the inputs of the 28M must always be directly sent to the outputs unless there is a way to change this.


Okay I think I’ve solved it.

I started up the 28M in ‘Class Compliant’ mode, which I think is a new feature allowing it to be used with an iPad.

This stops the inputs going straight to the outputs.

Start up holding the C button to do this, for anyone having the same issue

Seems the new Mac Pro is just a big iPad after all!


You should be able to set up the mix the way you want with the DSPMIXFX mixer.
You really didn’t give any more routing info than in your first post.
You are listening using what?
You are plugged into the MAC over USB? Using ASIO driver?
What are the outs of the 28M wired to?

i too am having the same problem using windows 10 - Cubase 8.5 pro - with mackie’s onyx blackbird interfaces…just can’t seem to silence that clean channel. its almost as if the fx is coming out the left headphone and the clean out the right