UR44 inputs & monitoring with Logic Pro X


I am looking for help regarding how to stop the audio coming into the UR44 interface’s inputs from immediately being routed to the main monitor output. I am using Logic Pro X, and would prefer to only hear the audio coming into the UR44 when input monitoring a Logic audio track that’s been assigned a UR44 input (3/4, 5/6, etc.). As it is now, whatever audio is coming in to the UR44 is being routed to my monitors regardless of whether or not I have created an audio input in Logic, and it’s mono even though I’m coming in stereo via inputs 3/4. If I do have an audio input in Logic, and have it record or input-enabled, as well as having ‘software monitoring’ enabled, I can then hear the audio in stereo, but ALSO the mono version that I mentioned before, and it’s obviously phasing and annoying.

Thanks in advance for your help!

Sorry man,

You seem to know way more about this stuff than me. I only use my UR44 for a podcast… 4 mics and thats it. As for Logic, I just know enough to get by.


No problem. Thanks for checking it out!


If you don’t want to use the direct monitoring, mute the corresponding inputs in DspMix app (or solo the Daw channel).

If you are using direct monitoring and are recording a stereo source, pan the pair of inputs in DspMix hard left and hard right.

Thank you so much!

just mute the input in ‘MIX 2’