UR44 iOS Garageband: No sound input

Hi all,

recently I tried to use my UR44 with Garageband on my iPad Air 2 (iOS 10.2.1). Garageband “sees” all the inputs (1,2,3,4,5,6,1+2,3+4,5+6) and let’s me select the audio source among them, but I just don’t manage to get any sound. For example, I plug the guitar into input 1, create a new track, select input 1, enable monitoring - but don’t get any signal into Garageband (neither on the track when recording, nor via the monitor output). I already tried to eliminate any source of error, so here is what DOES work:

  • dspMixFx works just as expected
  • using exactly the same setup, I get a signal from input 1 into any other app like Cubasis LE, JamUp or Audiobus
  • I even get the signal from input 1 into Garageband via Audiobus
  • I get a signal in Garageband from iPad’s builtin Mic if I unplug the UR44
  • the UR44 works flawlessly in any way on my MacBook (Studio one and Garageband)

I also tried it on my iPhone 6 - with exactly the same behavior as described above. So I’m either just to stupid, or there is some problem with UR44 + Garageband for iOS. Strange enough, I’m sure it did work when I tried some time ago (not sure which iOS version that was back then).

BTW: UR44 firmware is the latest and greatest; Garageband version is the latest, too; the Loopback Switch is off.

Anybody else encountering a similar behavior? Or any ideas what I could have messed up?

Any hints are welcome!



I have similar problems with Garageband and the UR44 interface. I think the problem is the combination of the UR44 + Garageband + Audiobus (3?). Maybe you could try the following to make the UR44 work in Garageband again:

  • delete Audiobus
  • delete Garageband
  • restart iPad
  • reinstall Garageband
    I’m not sure that you have to delete Audiobus completely but I’m pretty sure that the UR44 stops working in Garageband after you have connected Audiobus and Garageband once. (tried this 2 times on the iPad pro 10.5)

Another problem I have with the UR44 + Garageband is that inter-app audio stops working in Garageband when the UR44 is connected: the sound is distorted for every app I’ve tried.
I think these problems are Garageband bugs because other usb-interfaces have similar problems:

Maybe too obvious but since it isn’t mentioned in the two posts: Before connecting the UR44 turn it off, turn the CC (Class Compliant) switch on and then power up the UR44.

As the UR44 does work with other apps this cannot be the problem. I think this is a problem with UR44 + GarageBand + Audiobus as described above: The UR44 stops working in GarageBand after Audiobus 3 has been connected to GarageBand once. Maybe someone with the same configuration could verify this?

I’ve got the same problem. I’m using the UR 44 with an iPad Air 2, Apple Camera Connection Kit, the latest version of Garage Band, and both iOS 10 and 11.

Garage Band sees all the inputs, and they can be selected, but there is no signal. I tried the exact same set up with an Alesis Core 1 interface, and it worked perfectly, so I can only conclude the UR44 no longer works with Garage Band.

The original box says that it’s compatible, but I can find no mention of Garage Band on the Steinberg site or on major retailers’ sites. Has Steinberg quietly (no pun intended) ditched iOS Garage Band support?

I have the same problem too. Has anyone found a solution?

With the new garageband update the problem for me has been solved.