UR44 power problem

Power indicator does not switch from flashing to being continuously lit in my UR44.
When I connect the USB - driver is not installed on your computer.

The first day UR44 worked with no problems, but the next day the computer not found UR44. I reinstalled Tools for UR44, but without result. I tested UR44 on the second computer and the same problem - the driver is not installed. Please help me where the problem can be… Thanks.
ur44.JPG

Did you fix your problem in the end? I had the same issue.

I’d say if anyone else has this issue, try unplugging the interface from power and usb for a minute or two, reboot and plug it back in and turn it on.
If that doesn’t work try doing the unplug and re-install the software and drivers, restart and then plug it back in and turn it on. For me that was when it gave me the “windows has successfully installed the device” notification as opposed to getting a fail notification and it being not recognized.

I’m on Windows 7 Service Pack 1. The UR44 was working on day one, on day two it was unrecognized by windows, my DAW and also wouldnt show up in dspMixFx regardless of reinstalling all software and drivers/updating them. I was starting to assume that it was something to do with that I couldn’t get activation working on the software but it started working again and I’m not sure what it was that I did to fix it. It seemed to work again when I had unplugged the UR44 from the wall and from the computer for a few minutes. I’m not sure the problem was caused by sleeping the computer and then turning the UR44 off during sleep without using the “safely remove hardware and eject media” option before sleeping. I did a reboot test and It still worked fine after a reboot where I just left the UR44 running. I noticed the setup wouldn’t re-install the driver if it is already installed. So to do a re-install you have to uninstall it manually first or it just sees that you have the driver and skips that part without telling you. It did the same for the software pack but it did tell me that it was already installed with that.

I had to get the most recent firmware or driver update which was not in the main updated download folder on the website:

https://www.steinberg.net/en/support/downloads_hardware/yamaha_steinberg_usb_driver.html

Didn’t have to log in under admin like the user manual indicates.

Prior to that I had installed everything that came on the cd and the drive update file on their website with all the same stuff. Computer wasn’t recognizing it (flashing power light).

If the above link becomes inactive just keep searching until you find something that looks like:

“Yamaha Steinberg USB Driver 1.9.9 · 18.6 MB
Release Notes (PDF)”

I believe it is the driver only, without all the other stuff. Same zip file name though. Weird. Thanks for the headache Steinberg.

Hi
having same issues. the ur44 doesn’t recognize anymore on my machine running on windows 7 service pack1 though it worked fine for last two months the power lid still going on blinking. I’ve installed a fresh copy of windows and tried all your probable solutions you suggested above, still no luck. this is very frustrating for me. anymore to do ?? please suggest. thanks in advance