UR44 problem with powered USB Hub

Hi.

I have a problem with my UR44’s power. I’m using a 2017 MacBook Pro which only has two USB C ports for device connection and so, quite obviously, this automatically requires the implementation of some kind of USB hub in order to use the UR44 as it only has the USB 2.0 connection. This in itself, I’ve discovered a little too late, is troubling because Steinberg make a point of saying in their product manuals not to plug the UR range of interfaces into USB hubs. I’m assuming this advice is just being ignored by anyone with a laptop that is only equipped with USB C.

My problem, more specifically, is that I went and bought a Belkin USB 3.0 4-Port Hub, which is powered by it’s own wall wart. Being aware that USB 3.0 is backwards compatible I figured it would be fine to use with the 2.0 connection on the UR44 but when I try to use it (with the UR44 powered with its own included power supply) the power cuts out approximately every 10-15 seconds. After a little research I think I’ve discovered that this is because a 2.0 device can only handle 500 mA of power in comparison to the 900 mA of USB 3.0. Am I getting that right?

What confuses me is that I thought that since the UR44 was already powered with its 12V adapter, this shouldn’t have been a problem. What’s more troubling is that I also bought this Belkin hub in order to connect some other hardware, specifically a synth and a midi controller, and I’ve discovered they’re both equipped with 2.0 connection. Will I have the same problem with them?

Obviously I’m not very clued in with USB, so what am I missing? What is the exact nature of my problem and what are my potential solutions?

Thanks.

hey reece, did you ever get this worked out?

my 2019 macbook has thunderbolt ports so i can’t connect my UR-RT4 USB 2.0 cable directly. i tried using an unpowered hub that i’ve used for other interfaces but it won’t connect. the usb light on the unit just blinks and blinks.

trying to figure out what hub or cable to use

did you tried a USB-C to USB-B cable already?

i did not! i only tried a USB-C to USB hub but that would not work. perhaps one cable between the interface and the computer would work better (if replacing the interface cable is not an issue)

thanks!

Did you get it to work with a cable?

I’m having the same issue with a Macbook Pro 16in 2019.

Only USB-C ports. Bought adapters and hubs and my UR44 only shows up for a while and then disappears from the list of audio devices.

Help!