UR44 Recording Glitches - Skipping and Weird Noise


I was wondering if anybody knows what might be causing the issues I’m having with the UR44. I tried recording a simple stereo, 2-mic acoustic guitar bit, but upon playing it back I noticed that randomly in the recordings it would skip ahead. I looked at the files and they were actually recorded like this, meaning it’s not a playback error, it’s a recording error. I tried recording using just the default windows audio and the mic that came with my computer and this issue didn’t happen. I also tried reducing the rate from 192kHz to 96kHz and the issue continues. To me it seems like the buffer on the device is getting full, so it clears everything in the buffer then continues recording.

Another problem is a weird noise glitch. I’ve attached a 2-second wav file containing one example of the first issue and one example of this noise issue.

I’m using PreSonus Studio One 2 Artist, with two AT2035 microphones. I’ve rented Roland USB audio interfaces before with the same mics and this didn’t happen.

Please let me know if you’ve seen this before, and if there is a solution!



Hi Fabio,

I have the same problem you had, I bought the UR44 three months ago and I’m caming crazy, in contact with the Steinberg’s support but they are not able to help me, no one seems can help me…
Did you get the solution??

Are you Italian?? I’m from Milan, if you want we can write in italiano??

attendo tue!!


fabio (anch’io!!!)