UR44C cannot be found

I use AMD pc with windows. UR44C. I ve been using it for 9 months. It was ok. But yesturday it stopped. All lights are on. But computer does not see it. I tried to reinstall drivers from steinberg. Tried to reinstall tools for ur-c - but it s empty select-panel
Ok. then I installed a yamaha steinberg usb driver. it was installed ok. I reboot comp but its just cants see it.
ok/ then I tried to install everything on another pc and thats ok. its working. May be the priblem in my AMD Windows. CAnt understand.

Than I uninstalled everything. And installed it again, the select panel was ok this time. but it still not seen by AMD pc.

Including the white “USB” LED?

yes! It is blinking.

Info of device is
“Windows cannot start this device because its configuration information in the registry is incomplete or corrupted. (Code 19)”

Some things to check (I know some of this seems silly, but its part of the troubleshooting process):
Try a different USB cable
Try a different USB port (ideally one on a different chip/bus if your motherboard has more than one)
Try it on a different PC altogether (just to make sure the UR is ok).

Yes I tried another cabel - usb3-usb3 - does not work/
I tried another port.
I tried another pc - it works well.

But i think problem is in the AMD drivers. Basic AMD high defenition audio device does not work too.
So I am trying to look here now