Urgent: can't launch Dorico

Dorico 4.1.10 was working fine a few days ago. I’m on macOS 12.4. Today I launched it (several times) and it gave me:

• Spinning beach ball eternally
• Hangs on the splash screen at “Initializing SKI Plugin Controller…done”
• Or gets past the splash screen then does nothing

I’ve tried:

• Checking Steinberg Activation Manager (it says Dorico Pro 4 is activated)
• Restarting the computer
• According to another forum thread, looked in my App Support folder > Steinberg > Dorico for userlibrary.xml. That file doesn’t exist there.

After an hour of experimentation, I got it to launch once, got my project open, did a bit of work, clicked the Print tab, and it went to an eternal spinning beach ball. I haven’t been able to get it open again since.


Sorry I can’t help you, but you really had Dorico 4 working on OS 10.12.4? I didn’t realize that Dorico 4 would work on that old an operating system. If so, that is the OS I use and would love to try out Dorico 4 on it unless that OS is actually your present issue.

Hi @user450 , I too have Dorico and Mac OS 12.4 Monterey and all works perfectly. I recall Daniel saying that if you decide to uninstall/reinstall then make sure you make a copy of your Dorico folder first incase all your previous work is deleted. In iCloud I have a Dorico folder with a tiny little Dorico icon inside the folder symbol. If you have such a folder, back it up somewhere, along with any other folders you store your projects in.

Uninstalling/reinstalling may solve the problem.

Hi @user450 , can you run the attached script? It shall create a zip file on your desktop.
CreateDoricoDiagnosticsReport.sh.zip (548 Bytes)

@Ulf - I downloaded this but it unzips to an .sh file, which opens in Xcode, but I don’t know how to actually run it. I just see all the code.

@John_Ruggero: macOS 12.4 not 10.12.4. :slight_smile:

Too difficult to explain right now. Can you zip up manually all the folders mentioned in that script?

I think I got them all. Thanks @ulf.

dorico logs.zip (717.3 KB)

Hi @user450 , thanks for the data. It appears that Dorico is trying to attach to a zombied audio engine process and waits indefinitely for an answer. Please open Activity Monitor app and look for a process called VSTAudioEngine and kill that off. If you can’t succeed to do so, simply reboot your machine and see how it goes afterwards.

Yes, that indeed solved it. Thank you @Ulf.

Strangely, in my original post, I mentioned that I restarted the computer, and that didn’t fix it. I have no idea why. I don’t run any other apps (e.g. Cubase) that might use the VST Audio Engine.

Anyway, it’s fixed and I’m back in Dorico. Thank you!

1 Like