USB disconnect problem

Hi Does anyone have an issue whereby they leave cubase open (PC) and after an hour or so of non use the USB components loose connection? On the odd occasion the same can happen within minutes.
I tried moving all the USB cables to see if any intermittent issue but none.

For example my CC121 always looses connection and the blue light flashes to show no connection.

I can sometimes just sit back and leave the pc alone with Cubase open and after an hour or so I can hear USB connections disconnect and try to reconnect.

I am wondering if I my 10 way USB interface is a bit dodgy as this has the CC121 and CMC controller attached.
I dont think this is the issue because I am pretty sure the CC121 did this before I have the CMC controllers and the 10 way interface.

Anyone with similar issues.

Are you using windows, right?

You can try to turn off USB power management:

https://www.youtube.com/watch?v=3IaQb0OAfbQ

Yeah windows 7’ thanks will have a look.

Two areas to prevent the system from shutting down USB ports to save power. It is basically the same for XP up to 8.1.

Power Options

  1. Control Panel --> Power Options --> Change plan settings link --> Change advanced power settings link.
  2. For each power plan, change USB settings/USB selective suspend setting to Disabled.

Device Manager
If the above doesn’t fix your issue, you may need to explicitly disable power down on each port. I do it anyway!
This is the steps that the video above covers.

  1. Control Panel --> Device Manager.
  2. For each item under the Human Interface Devices and Universal Serial Bus controllers sections:
    __ 2.1) Double-click to open its Properties dialog.
    __ 2.2) If it has a Power Management tab, click on it, else skip to next item.
    __ 2.3) Uncheck the Allow the computer to turn off this device to save power box. Ignore if greyed out.

There can be a few, so a quick key sequence for each item is:

  1. Down arrow --> select next item.
  2. Enter --> open its dialog.
  3. If Power Management tab, Crtl+Shift+Tab --> open panel.
  4. If box checked, Space --> uncheck.
  5. Enter --> close dialog.
  6. Repeat for each.

Note that if you plug a device into another port, the setting may be reset to the default for the port, so just double-check each time you finish rearranging USB connections.

Thanks guys, I unchecked the power management for each of the USB connections. Cubase has been running for around 14 hours now (without use) and all connections still good. Pretty sure this has fixed my problem as it never goes more than an hour or two without disconnecting. Thanks again.

Sorry to necro an old thread - just wanted to say thanks Patanjali for this info. I was getting wacky behavior amongst my various USB peripherals, and realized that I had moved some cables around. I had forgotten you need to explicitly disable power management on a port by port basis, and had forgotten to do it after I moved things to new ports. Thanks for saving me a lot of headache!

You’re welcome. Glad it helped.

Also many, many thanks from me :wink:!! It helped me to fully install the Yamaha Asio driver again and stopped the awful sound quality and glitches after using an other usb port!!

(All I have to do now is cancel my USB hub, I ordered today, because I thought is was a power shortness :smiley: )