USB E-Licenser dead

I had an older one for years. When I transitioned from PC to my Mac, it died.
I happened to have a 2nd one that was purchased for VEP.
Since updating to Ventura, the exact same thing happened.
After upgrading I opened Cubase and got the e-licenser control error as I had Amped Elektra installed.

After going thru the maintenance procedure on the original key, I got a message informing me that the key was damaged.
This time did the maintenance and got an"ok’ for all but one of the 6 steps (related to memory) and still not working.

Really stumped.

I would find another computer preferably Windows, to do elc maintenance on, to see if that works.

Thx for the suggestion.
Checked the key on my Win 7 machine - all is good.
Saw something on this forum about possible USB3 compatibility?
Im on a Mac Studio, have the key plugged into a USB3 hub.
Could that be an issue?

I don’t know, but I was thinking that maintenance on another machine might allow the key to work on the Mac.

Problem solved.
Plugged into different USB port.