USB E-licenser not working/not recognized

Yesterday I decided to reinstall windows and everything went well until i got to opening up Cubase again.
I have the USB e-licenser but the Cubase doesn’t somehow recognize it.
a6ed0c963df45b32ee6069a61936375c.png
And it asks for an activation key. I have the activation key on my profile at “https://www.steinberg.net/en/mysteinberg/my_products.html”.
But the activation key is already used for the USB e-licenser activation so i can’t reuse it.


Did the steps that are told in this page but none of them worked out for me.
E-licenser control center does recognize the USB so that’s good.
And
But when i go to open up Cubase it doesn’t recognize it anymore.

Ps: I tried to reinstall Cubase too but it was no help.


This is the message/ticket i sent to Steinberg support but decided to post here too!
I’m very impatient because making music is the only thing i love to do on my freetime…
It’s only been like 2 weeks now but i’m getting some withdrawal symptoms :laughing:
If you have any tips or thing i could try i really could use the help on this one…

Hi,

Cubase AI/LE/Elements is not stored on the USB-eLicenser by default. Are you sure you transferred the license to the USB-eLicenser on the past?

If no, Reactivate your license from the old Soft-eLicenser to the new one.

If yes, make sure you have installed the right Cubase version. For example you can’t start Cubase 10.5.x with Cubase 10 license.

Oh god yes! I had the wrong version of Cubase downloaded. I feel so fricking dumb right now lol :smiley:
Started the download and i’m soon back to making music!!

Hi,

You are not the first one (otherwise I would come to the idea for the very first try) and most probably not the last one. :wink: