USB eLicenser not recognized (Windows 10)

Hi guys,

So I finally purchased Cubase Pro 9 a few days ago and have been having some issues activating my license. The installation appeared to go smoothly, however, I have been unable to activate my license due to the USB elicenser not being recognized by my computer or eLCC. I am getting the following message every time I plug in the elicenser, “The last USB device you connected to this computer malfunctioned, and Windows does not recognize it”.

I’ve tried running through the list of recommendations on Steinberg’s troubleshooting webpage to no avail. I’ve done a clean reinstall of the the most current eLCC (version 6.10.5.1209), tried every USB port on my machine, and yet nothing seems to be working.

I have already put in a service request to Steinberg support but wanted to try my luck here as well. Has anyone else run into this issue and found a solution?

(BTW I’m using the brand new Steinberg elicenser that came with the boxed version of the software.)

My thoughts…

Try running the eLicenser software as “Run as Administrator”.

Are you running USB 2 or 3? I believe the USB eLicenser requires (or sometimes works better on) a USB 2 connection.

Regards. :sunglasses:

Hi and welcome,

Make sure your USB-eLicenser is plugged o USB 2 not USB 3 port, please.

Thanks for the response guys. I have tried both USB 2.0 and 3.0 ports on my computer. Still no luck. I will try the “Run as Administrator” trick when I get home this evening. As a side note, Iv’e noticed when I initially plug it in, the red indicator light will come on and slowly get brighter until it turns off about 2 to 3 seconds later. As soon as the light turns off, I get the error message mentioned earlier.

What is your motherboard?

Hippo

[quote=“Hippo”]What is your motherboard?

Not sure what type of motherboard I have but the computer is an Acer Predator G6. I tried plugging it in to my old HP laptop that runs Windows 7 and had the same result so its not specific to the Acer only.

I also tried to run the eLCC as Administrator but that didn’t seem to help either.

Steinberg support has agreed to ship a new USB device with the impression that the device itself may be malfunctioning. Hopefully this will resolve the issue. Thanks for your responses everyone.

Hi
I’m having the same problem with the elicenser not being recognised. I’ve tried everything to resolve the issue but to no avail. Would a new elicenser resolve the issue?

Hi,

Could you try the USB-eLicenser on other computer? Just to verify if something on your computer is wrong or the USB-eLicenser is broken.

Hi there
Thanks for responding. I did try it on two other laptops and the message was the same, that it wasn’t recognised. I’ve never had a problem with it before.

Hi,

Then I would say the USB-eLicenser is damaged. Please follow this article.

Hi
Thanks for that. I have ordered a new usb elicenser which should arrive tomorrow. I’ll follow the link you sent and hopefully that will resolve the issue.

Hi there, i had the same issue with the usb dongle not showing up in the control center on my Windows 10, i tried all the usb ports and all the rest of tips, i found that the application “Duet display” (for windows) was the issue… check your startup apps, maybe you can find there an app that has to check the inputs to recognize a device that causes the issue.
Now i can place my dongle in every usb hole i like without any problem like it should be :slight_smile: