USB midi controllers set up properly but no response in Cubase

I have two usb controllers and I can’t get either of them to do anything in Cubase 11 elements.

Both are detected, and I have them set up properly in studio setup and midi ports, but button presses don’t get registered and I can’t do anything with them. They work fine in other DAWs (example BandLab web sees them immediately). They also work fine if I connect the, via din connector to my interface but I have multiple devices so I don’t want to have to do that all the time.

I’ve tried very permutation of settings and tricks I can find on the web… Cubase just doesn’t want to listen to the midi they are putting out.

Any help would be so greatly appreciated.

[p.s. Arthurian key step 32, and launchkey mini mk3 (not connected in photo). I had an mpc mini that I think worked fine but I learnt it to a friend]

What specifically do you mean by this?

It is really difficult to make any useful suggestions when all you are telling us is - I’ve tried EVERYTHING and NOTHING WORKS

Tell us what you are doing step-by-step.

It looks like your MIDI In’s are working since there are MIDI Parts with Notes in them on the Tracks. It also looks like you are playing external synths. Maybe simplify and try to get a VSTi working as a first step.

1 Like

ok yes good point. and thank you for responding!

I play the keys, there’s no midi registered in the bottom corner. The tracks don’t pick up any midi inputs either (no blue bars, if I enable/record/monitor, still nothing). The HUI controls don’t work either but honestly that’s secondary; I need to be able to play the keys and I can’t even get that.

The only thing that “does” seem to work is that if I set up the Mackie HUI config for either device, then the pulsing input does register in the bottom right corner [I think it’s like a “keep alive” signal from the controller]. But still nothing on the tracks that are supposed to read from them at all. And the HUI control dont’ work either (transport, etc).

When I say I “tried everything”, I mean, I’ve thoroughly been through every setup for these devices I could find, and tried debugging protocols from random web/forum/reddit posts. I’ve shut down cubase and opened it up with the stuff connected and disconnected, I’ve clicked off and on “all midi in” for each of the combinations of inputs that show up [the launchkey in particular has a quirk where you are supposed to disable one, but it doesn’t matter what I do, it’s a technicolor brick on my desk with cubase].

I’m convinced the devices are working fine. They show up in device manager. They are sending midi to other DAWs [bandlad web is easy to test]. And my cubase has no issues taking midi from the steinberg interface, but that’s the only USB device it seems to like and I have only so many DIN cables to snake around my desk. When I only had the launchkey, I figured it was something quirky about that device. But I just got the Arturia today and I have the same issue with it now too.

This is getting long but just to clarify, the midi parts there were drawn in by hand (mouse). And the external synth I was recording audio only. I could not record any midi from any of the devices over USB. I was able to get midi from their DIN connectors connected to the steinberg interface, but that is an impractical studio setup for me because I have two synths and a controller for each. Also it woudl be nice to be able to use the Mackie HUI controls on at least one of them eventually.

If you are on a PC what does Device Manager>Sound, video and game controllers look like?

Also do you have anything that actually uses DirectMusic? Not suggesting it’s causing problems, just unneeded.

Thanks again, I really appreciate your help.

The devices all seem to show up properly in Device Manager, they are listed, no exclamations or problems flagged. Below you’ll see with the Arturia keystep connected.

As for the DirectMusic, I don’t normally have it checked. It was just one of the many things I tried to get this to work.


Hm, somewhat sheepish update from me now.
The only thing I had not tried was crawling under the desk and trying a different USB port on the PC. It defies all reason that all my devices including these controllers would work fine on the front connectors, except in cubase, because of somethign to do with the port, but… here I am, seeing it apparently working fine, connected to the USB hub snaked out the back.

Raino, I truly appreciate the assistance. I’m gonna give it a few days but I’m hoping this very weird fluke is the fix.


1 Like