usb midi keyboard not triggering vst instument

I cannot get my midi to trigger any vst or midi instrument…when I press any key on the midi keyboard, i see a red signal on the transport bar but no sound. Im using cubase 6 le on mac running lion

Same thing was happening to me. Turns out it was my Presonus Audiobox that my keyboard was plugged into. It was brand new but needed to download the updates from the company. Once the update was downloaded, it worked great.

Aloha o,

Did you load a vst instrument either as:

1-a MIDI track (using a VST instrument in the VST Insrtument Rack) or as

2-an Instrument Track (using its own VSTi)

Also make sure your MIDI keyboard is sending MIDI info on the same
MIDI channel that the VSTi is set to receive.

i see a red signal on the transport bar

Which means that MIDI info is getting into Cubase so you are almost there.

You just need to get it routed to the correct locations and make sure
there is a VSTi set on the correct MIDI channel and ready to see that signal.


still not working…not only does it not trigger vst instrument, its not triggering any instrurment at all. not working for reasons rewire either. i have a tascam fw1884 which i tried via midi…didnt work. I have the keyboard via usb to mac, still not working…it works for logic, and it works for reasons standalone but just not for cubase le. It was working before and it just stopped…I reinstall cubase 3times and still nothing…dying here

problem solved, every thing works perfectly now…it was a matter of unchecking stuff in midi filter

Thanks for the post, you saved my sanity. I have spent 6-8 hours trying to figure out why my MIDI piano was suddenly not triggering my Ivory Pianos (VST plugin). It was working fine all last year. I went through the control panel, everything I could think of. I was about to give up on Cubase when I saw your post.

I’ve never touched the MIDI filter (to my best recollection) but…

In my case channel 1 on the MIDI filter was selected. I must have been transmitting on channel 1, which is usually the default channel. It’s not obvious at first that the channel is selected in the MIDI filter but sure enough, when I clicked on the channel it was obvious that somehow it had been selected. I started getting a MIDI signal in the Ivory Pianos control panel - yeah!

For anyone suffering through the same experience go to Cubase preferences and select the MIDI section to see the filters. I am finally back to recording (Whew). I need to get my Cubase videos out and go through them again. I’m not ready for yet another upgrade until I master Cubase version 6.5. Thanks again for posting the solution here.

1 Like

I had the same issue. What I did was press Ctrl+Alt+Shift as menioned here ( I then selected Disable Preferences. Everything now works correctly.

Many years later, I have had a similar issue with Cubase 8.
I have a MOTU Midi Express XT.

I found numerous discussions online about getting it to communicate properly.
One of the issues were that I could put in midi signals manually and it would play back correctly out of the assigned output. I could also play notes on my keyboard and it would record the notes but not send the notes onward to the assigned synth.

Like there was some sort of blokade.
I opened the midi filter and nothing was set to be filtered apart from sysEx. I assigned it to filter everything and tried that. nothing worked.
Then unfiltering everything again did the trick.

For some reason it was filtering stuff it said it wasn’t. so now it works as intended.
I can now make noise again.
thank you!

I was stuck in this same situation with Pro 10.5. I could see the midi activity from controllers registering but no response from vsti.

It wasnt clear if the midi filter channel 1-16 buttons were on or off. I even thought I had tried both ways.

Im working again thanks for the posts in this thread.

I have the new version Cubase 11 Element and have almost the same problem as you guys. First off, I would like to say that I’m new to these stuff. I am using a A25 Komplete with Cubase and I’m getting a clear midi signal. all the knobs are working but no sound. When I use the mouse on the virtual keyboard it makes a sound but not woth the usb keyboard… am I using cuabse wrong. Am I for example choosing a wrong track type? I’m will soon get anger issues beacuse of this :slight_smile:. If anyone could help It would mean a lot to me!

Duplicate post.