Using StudioLogic Mixface with Cubase

Hi - I’m trying to understand setting-up of the SL MixFace used between my keys and Cubase (Artist 10.5) on W10 PC.

The SL device is presettable to use Cubase as the DAW, and signals are being fed through to Cubase but with no particular control / action settings. The SL support has not been too good on this so I thought I would ask here. I have downloaded and installed the special Cubase interface s/w, and MixFace is talking to Cubase as far as I can tell.

If anyone else is using this device can you tell me if I need to program every control function separately please? Do they save this config for each use?**

I thought there would be some built-in presets for common controls which could be altered ‘to taste’ (e.g. basic channel controls stop start etc.)
Not working for me, although I have followed SL setup procedure and YouTube demos. They don’t describe what might be wrong and make it look too easy.
I also tried after a MixFace factory reset and Cubase DAW selection again - no luck.

**Also does Cubase need to be set up for every new project to recognise the MixFace control signals please?

many thanks
Colin (UK)

Hi,

I have my Mixface working perfectly in Cubase 10 Pro - both in Windows and Mac. So, let’s narrow down your problem a bit, while you probably have done all this already if you have followed the support videos etc. I understood that nothing is working for you, for example, start/stop buttons.

  1. Have you installed Steinberg SKI extension? (https://www.steinberg.net/en/support/content_and_accessories/steinberg_ski_remote.html)
  2. Have you added “Mackie Control” device in Cubase (Studio -> Studio Setup -> Remote Control) and set MIDIIN3 (SLMIXUSB) and MIDIOUT3 (SLMIXUSB) as your MIDI input and output ports in that same setup dialog?
  3. In you Mixface SL, are you in DAW mode and have configured the port to “USB DEV” and Type to “Cubase-Nuendo”? (DAW mode -> Edit -> Global settings -> DAW port and type)
  4. Have you used some other program than Cubase to see if you are getting MIDI data in properly? For example, go and download&install the free Pocket MIDI (https://www.morson.jp/pocketmidi-webpage). Open it up and set the input port to MIDIIN3 (SLMIXUSB) and check that you are getting MIDI data in. For example, if you hit the Play/Stop button on Mixface, you should see in the MIDI in monitor:

Port1 Ch 1 NoteOn 90 5E 7F [A#5]
Port1 Ch 1 NoteOn 90 5E 00 [A#5]

Transport buttons should always work and they are not configurable - they should work in either DAW or control mode. For control mode, you can map whatever MIDI messages you want to be sent for each knob/slider. And store them in the program slots.

Hi and thank you.
OK - I had done steps 1,2 3. and have now done those steps again.

Watching the input SLMIXUSB in Pocket Midi, (all filters cleared) the 16 channel controls plus master vol send midi info.
No other buttons send any data.

I have a keyboard through UR22-II which I can monitor - Midi data looks OK and seen by Cubase
I have a separate USB input device AKAI LPD8 which PocketMidi says Port Open Failed so cant monitor (but works OK into Cubase)
IE Both of the above are inputting OK to Cubase - no midi device is inputting via Mixface at present

What should I see or do in Cubase next to test it. There appears to be no control from Mixface at all.

Thank you for your help…
Colin (LowTech)

Hi,

Starting with side note, Pocket MIDI cannot probably open the LPD8 port because you had Cubase open. I have LPD8 as well and it does the same - Pocket MIDI has to be the only application trying to read the port of a MIDI device.

So did I understand correctly that if you select SLMIXUSB in Pocket MIDI you can see MIDI information if you move faders or turn knobs but nothing happens when pushing transport buttons like play/stop etc.? Actually, that is normal behaviour in case you are in CONTROLLER mode of Mixface, because Mixface as 3 different MIDI ports (as listed by Pocket MIDI):

SLMIXUSB = Midi port 1, which is for data fader/knob coming from Mixface when it is in CONTROLLER mode.
MIDIIN3 (SLMIXUSB) = Midi port 3, which is data coming from Mixface when it is in DAW mode - also transport button data ALWAYS comes through this port!
(…and MIDIIN2 (SLMIXUSB) which is used for firmware updates but have no other use)

So, when you have selected SLMIXUSB in Pocket MIDI and you are in CONTROL mode, you only see MIDI messages from faders and knobs, like you saw. If you press eg. play button, its output is always going to Port 3, not the port “SLMIXUSB” you are reading. Now, what you have to do is to select MIDIIN3 (SLMIXUSB) in Pocket MIDI. If you do that, you should see messages like I posted above no matter whether you are in CONTROL or DAW mode, because Mixface always transmits those buttons through its port 3.

Still, this does not explain why it does not work in Cubase - unless you have there as well selected SLMIXUSB instead of the “MIDIIN3 (SLMIXUSB)” in your Studio Setup menu’s Mackie Control device?

OK I now have something working:

Studio setup Mackie control Midi Input reads MIDIIN3 & Output reads MIDIOUT3
Smart Switch delay is SHORT
Enable auto select is ON

Mixface has to be on and set up before opening Cubase (as for any USB connected devices). Will it remember my settings?

SL display shows CUBASE
DAW / CTRL is Lit ----- suggesting CTRL function not DAW.
Voluime and pan controls work per channel in use
Moving Vol slider switches to the appropriate Cubase channel (moving Pan does not) and lights the Channel (below slider)

BUT
(1) Moving any VOL slider also moves Pitch control of the channel at same time ??
(2) Moving Master VOL also moves Pitch control of active channel ??

(3) Pressing Channel button sends a note to that channel ??

ps on the SL Mixface, is Button Led Lit the first or the second state please? It doesn’t say.
also on the Select buttons one is always Lit. Is this correct

Thank you for your help. I am sure there will be more queries as I learn and sort out other operations, if I might add them to this thread.

many thanks
Colin

Hi,

I don’t have access to my workstation now to test this out but what comes to my mind is you may have the same MIDIIN3 (SLMIXUSB) input defined for “Track Quick Controls” - which can also be found in the Cubase Studio Setup menu. So your same MIDI input goes to both Mackie control and these quick controls - and if Mixface sends by default CC1 message, it happens to be pitch bend. Test by removing MIDI input from quick controls.

For (3), button presses on Mixface do indeed send midi notes. You need to select which MIDI input you want to use for your channel (instrument track, or MIDI track). By default the setting is “All MIDI Inputs” so all MIDI activity ends up as your channel input. Select your keyboard as input, or whatever input device you are using.

Hi :smiley: - thanks for the tips - just as you thought - it’s all becoming a bit clearer. There seems to be a lack of documentation from SL (on Cubase setup) on this i.e. not very comprehensive, so this post might be useful for others to ask similar questions on the SL Mixface device, as I am sure I will :unamused: .

In this case it was just a matter of disabling various inputs in CB Setup - my midi-ins bypass this device but I hope to run an SL73 or similar through it to take full advantage.

Many thanks for the help roja
Colin
(Lowtech)

Hello,

Had been having the same issues! and for sure it’s disappointing. I too wish they had better Customer Service or a video. However, after testing the StudioLogic controller, I’ve noticed that it is working and is mapped for Cubase for mixing ONLY. However, if you are attempting to use it for other platforms such as VSL, Kontakt, or Spitfire for dynamic control that is where the trouble comes in and where you get unintended pitch bending, maybe volume control, and it is mapped to the keyboard as midi input.

Unfortunately, At least, for now, I have found that additional controllers would need to be used, which are mapped in Cubase for the purpose of dynamic performance control.

Nevertheless, you CAN run the aforementioned programs with the StudioLogic SL Mixface as dynamic performance control using the Multi-Port configuration by switching DAW/CRTL button. Toggle by rotating to P01 Muti-Port and then go into the program you want to use in Cubase and then the program i.e . VSL, Spitfire etc. will needs to LEARN the desired switch and mapping config to your positioning. Once you finish your recording you can button back to DAW Cubase.
Keep in mind that if you do not have and blank or audio instants, which I mark as MIXFAC the SL starts acting like a keyboard crtl. and not a mixing board. This is somewhat confusing and not optimal but it seem to work well to have a separate instants to mix with.

I haven’t worked it all out yet, so there is room for improvement. If anyone is having an issue I can keep you in the loop. If you have a specific program you’re having trouble with let me know.

I should do youtube on this …hmm?

I hope this is helpful,
Parahawkmusic ( and you know the rest)