Using Transformer for ProgramChange

I’ve found an article that explains how to map CC# data to ProgramChange data in Input Transformer. I’ve managed to assign all the buttons on my Alesis VI61, so that it now changes the presets in Sylenth1 according the buttons I press. Great stuff!

My only problem is, the mod wheel is now assigned to a particular preset as well, being on CC#1! Is there a workaround, so that I can assign the VI61’s buttons to start at CC#2, thereby bypassing CC#1, so that I can still use the mod wheel for it’s original intention? I don’t need any of the other CC#'s, as it’s just for a live playing setup, where I need to change presets on the fly. I’m sure it’s simple, but I can’t see how.

Any help is greatly appreciated!

Roo McKeller


What MIDI CCs have you assigned? Could you attach a screenshot of the Input Transformer? What MIDI CCs do your buttons send?

There is an editor app for the vi61 you can download from the alesis site that you can use to assign the cc numbers for the vi61 so they start at 2. But, if you’re going to do that, you can also use the editor to assign program change numbers to the buttons and you won’t need the transformer.

Hi. I’ve tried that & it doesn’t work. The whole thing stops working. I wish Transformer wasn’t so complicated.

Is there a stable way of converting CC#32 data into ProgramChange data within Transformer? I’m getting some sort of response, but it’s quite eratic. I’ve checked my settings in the VI61 editor & the CC#32 data is being received by Cubase & converted by Transformer, but although the CC#32 messages being sent from the VI61’s first 4 buttons are values 0, 1, 2, 3, the ProgramChange values are being received as 33, 33, 33, 33, & as preset 32, 161, 289, 417 within Sylenth1. That’s a massive difference. Sadly, I’m not a MIDI expert, so I’ve no idea how to set this up or figure out where the translation error is occurring!

These are my settings:

Type is / Equal / Controller
Midi Controller No / Note is equal to / CC#32 (Bank Sel LSB)

Type / Set to fixed value / Program Change

Is this correct???

Hi Martin,
Here’s the screenshot of Transformer’s settings. I know it’ll be something simple…

As an update, I tried your initial technique, but I lost control of the mod wheel s it was then changing presets too. I still need to use the mod wheel. Thanks


Yes, this is correct.

In this case you would get a Program Change Number 32. If you want to use the value of the MIDI CC32 as the Program Change Number, add this to the bottom:
Value 1 > Use Value 2

If you want to assign one specific Program Change number to the CC32 (doesn’t matter which value do you send), add this to the bottom:
Value 1 > Set to fixed value > your value

Hi Martin,
Nothing is happening. Now Sylenth1 isn’t receiving any signal at all. I’ve attached screenshots of Transformer & of the VI61 setup page.


It seems to be working, but not as you’d expect. Cubase is receiving converted MIDI data on the ProgramChange channel, but instead of the individual presets changing within Sylenth1, the 4 banks are changing. To the best of my knowledge, these are changed with CC#0, not CC#32. What is strange, is that if I turn Transformer off & then manually add ProgramChange data to the midi editor, the presets then change, not the banks!

It’s driving me nuts!

You’re sending the bank change instead of the PC. You’re making this way too difficult :slight_smile:. Simply use the editor app to assign the PC values you want to the buttons.

Hi. It appears I have a faulty VI61. The values being sent were all over the place. It wasn’t actually sending out ProgramChange data, which is why I was trying to do it this way. It then sent both CC#0 & CC#32 data at the same time, even though we could see the settings were just for CC#32, then it sent correct CC#32 data, but at the maximum number of 128, instead of 1, 2, 3, 4 etc. I’m sending it back for a replacement.

Thanks for all your help. At least I’m familiar with Transformer now!


Could you try to add MIDI Insert MIDI Monitor? What data can you see in the MIDI Track?

Is the button really a switcher? Or do you send the value 0 once you release the button?

It’s working correctly, you’re just misinterpreting the bank change midi. You ignoring the msb/lsb difference.

It’s extremely unlikely that it is faulty. If it is faulty, transfomer won’t help you.

Hi guys,
The replacement VI61 has turned up & it’s behaving in exactly the same way. Cubase is not receiving ProgramChange data.

Or so I thought!!!

After speaking to Alesis, I was instructed to download Bome Midi Translator & they walked me through it’s setup. When I pressed the buttons on the VI61, IT IS in fact sending PrgoramChange data, which is being recognised by Midi Translator. So!

For some reason, Cubase is NOT recognising the ProgramChange data. It is receiving CC#0 & CC#32 data though. I’ve checked in the Cubase MIDI settings & nothing is checked in the filters. So I cannot see any reason why Cubase would think there is no ProgramChange data being sent from the VI61, unless this is some kind of Cubase bug that no one is aware of.

So, we’re back to square one, with me not being able to change the presets on Sylenth1 within Cubase, using the buttons on the Alesis VI61.

Any ideas as to why Cubase isn’t behaving properly???

You’re sending midi from an Alesis controller to Sylenth. If something is not working right, it’s hard to see how that would have anything to do with Cubase. Are you saying it works fine when you use another host besides Cubase?

Hi Glenn,
Right, I’ve got Cubase Elements 10 on my laptop, which is eventually what I’ll be using for my live setup. Everything is working perfectly fine with E10. The VI61 is changing Sylenth’s presets without any problem. I’ve checked to see if there is any difference in the preferences sections of each version & they’re both the same. I didn’t check this before because for all intents & purposes, both platforms should be the same, apart from Pro10 having more features than E10. This now makes it even stranger.

So why would E10 behave the way it is supposed to & Pro10 not behave at all??

I’ve also installed Ableton 9 Lite on my PC, which came free with the VI61 & that is working perfectly fine too.

It has to be a bug within Pro10, I can’t think why everything else is a simple case of plug & play & Pro10 is not even receiving ProgramChange data.


Record the midi in Cubase Elements 10, then record the midi in Cubase Pro 10. Examine the list view in each case and see how they differ.


Compare the data without the Transformer (Cubase Elements vs Cubase Pro) and compare the data with the Transformer (Cubase Elements vs Cubase Pro).

You can even open the editors side by side to see it (make a screenshot and attach it, please).

Unfortunately Cubase Elements doesn’t have List Editor, which is the best for this kind of tasks. Use the Key Editor, please.