Using VEP audio inputs on an FX track?

I used to use Altiverb on FX channels in CB7 but since Altiverb is such a CPU hog, I’m trying to use them in my VEP server. I’ve tried using a VE audio input as an insert on one of my FX channels, to link to an instance of VEP (server) running Altiverb and this seems to work, but only when the sequencer is stopped. As in, I can play a midi track live, with a send of that instrument sent to one of my FX channels with the Vienna Audio Input linked to the server running Altiverb. I see the input in Altiverb and the reverb audio runs back to CB and I can hear it, no problem. However as soon as I start the sequencer this send is cut off. Once I stop the sequencer, I can hear the reverb for a brief second.

I’ve got the solo defeats on on the FX channel so when I solo an audio track the send stays on. Don’t know why the send is cut off when I hit play! What am I doing wrong here? Anyone using this method? Or do you have to set it up in a different fashion? Of course using the VEP audio input as a send on an FX channel would provide a lot more flexibility and convenience, rather than having to use an audio input insert on every audio channel that you want to apply reverb to.

Any suggestions would be much appreciated!

Cmon! Someone out there must be using fx sends to a VEP server! How are you doing it?

OK, figured it out myself. In case anyone is interested, you set up an instance of VEP server either on your master computer or a slave machine with various input tracks inside, and whatever FX you decide to use on the inserts of those tracks. You also set the input and output channels on each of those tracks. Then set up an instrument track in CB, inserting the VEP server interface plugin on that track, and make sure it’s linked to the VEP server you just set up. Also turn on however many of the outputs you want in the settings on that track.
Now you create an FX track in CB, and create a VEP audio unit plugin as an insert on that FX track and assign that plug-in to the same VEP server you just setup. Also, assign the input channel to match whatever track you want it to show up in on your VEP server. Make sure the FX track has no output set on it. Now on any audio track or instrument output , you can select that FX track in your send column. That send should go to the selected track in your VEP server and loop back into the VEP outputs in CB. Of course you’ll have to assign that output of that return. I also have solo defeat enabled on all my FX tracks so when I solo certain audio or instrument tracks, the fx send for that track stays on.

1 Like

Hey Garehead,

I’ve just recently run into the same problem you described above. I have FX channels in Cubase with the VEP audio input plugin on them, which send audio to my VEP instance with altiverb, and then the audio returns to cubase from the VEP outputs like any sample library would. I can hear the reverb, but as soon as I hit play or record the reverb goes away and by looking at the Altiverbs I can see that no signal is being sent to them from cubase while it is playing or recording. I believe I’ve followed the description you posted here on how you got it working, but still nothing. Your help would be appreciated.


Thanks for that thread Garehead. I was suprised how little attention it got. Your second post really helped me out yesteday… Six years down the line!
Cinester, I suppose you had time to solve your problem by now :smiley: