UV22HR makes mono files stereo (?)

How can I prevent UV22HR from making mono files to be converted to stereo? Internal dithering seems to work properly…
I want to batch-convert list of mono and stereo files, apply UV22HR dithering to them and save them the way they were e.g. mono / stereo however I can’t figure out how (all the output files are stereo).
Is it me or WaveLab?

Confirmed. This is a plugin issue. I have reported it to Steinberg.
The temporary solution is to treat mono files separatly from stereo files. And to use as output file format the “Mono” setting with “Left channel”.

Another simpler solution, if you’re under Windows, is to use the UV22 version in the Legacy folder. This is the VST2 version, and it has not this problem.