UV22HR not working in Batch processor?

Hello, when I add a UV22HR with 16-bit output in a batch convertor with 24-bit files, the files exported are still 24-bit.
I just tried with 8-bit output, same thing the files are 24-bit. I have UV22HR in 20 different projects and it’s the same behavior.

Any idea of why the UVHR22 would not be working in a batch processor?
Any idea of another tool I can use to batch process a change in the bit rate?
thanks
Florent

The same thing happens if you do a normal render through the Master Section with dither if you use the file format factory preset “Wav default” (that preset matches the source file bit depth). The result file has 16 bit dither, but it’s 24 bit if the source file is 24 bit.

You need to change the file format on the batch processor “format” tab to the factory preset “Wav 16 bit”, or explicitly change the format bit depth to 16 bit there.

thanks so much, it works!
I am confused though, is this an expected behavior?
converting sampling rate with the Resampler works fine even if the “format” tab says “match input stream”, why wouldn’t it be the same situation with bit rate?

It’s always been that way with the “Wav Default” factory preset afaik. In that preset, Bit depth is set to “match source file”. You need to specifically change that setting to 16 bit, or use the “Wav 16 bit” factory preset, which has that setting changed.

From the manual:

https://steinberg.help/wavelab_pro_plug_in_reference/v9.5/en/_shared/topics/plug_ref/internal_dithering_r.html

“Dithering changes the sample resolution, but not the sample size. For example, when dithering 24 bit to 16 bit, the file will still be 24 bit in size, although only 16 bits of information will have significance. When rendering to a 16-bit file, specify the file resolution to avoid wasting space.”

The resampler match works, but the bit depth match logic can’t or shouldn’t work as easily to automatically make the file 16 bit if you’re using 16 bit dither, as far as I recall the discussions about this.

Ok thanks for the clarification.